PDA

View Full Version : 12" G4 iBook not seeing new harddrive???




dcains
May 15, 2008, 06:37 PM
Hi Group:

I just replaced the original 20gb Toshiba HD in my 12" white G4 iBook (1.2gHz, 1.25gb RAM) with a new Western Digital 80gb Scorpio drive. No real issues with the swap, except the new harddrive apparently isn't being recognized. Don't see it in either the Disk Utility or System Profiler, but I can sure hear it spinning after power-up. I know it needs to be formatted, but how is that possible without being able to access it with the Disk Utility?

So, what's my next step? Anything I can try without taking the whole damn thing apart again and checking things with the old harddrive? BTW, only trouble with the old drive was its size. I've been running Leopard on it for several months.

Thanks in advance for any assistance you guy are able to offer.

Dean



techound1
May 15, 2008, 09:28 PM
What are you running OS X from that you can't see the iBook hard drive in disk utility? Are you booting from a Leopard install disc?

dcains
May 15, 2008, 10:07 PM
What are you running OS X from that you can't see the iBook hard drive in disk utility? Are you booting from a Leopard install disc?

I'm running the Disk Utility and/or System Profiler from the Leopard install disk. All other hardware (e.g. RAM, optical drive, etc.) show up normally in the System Profiler.

dcains
May 15, 2008, 11:51 PM
Thankfully, second attempt was the charm. Took me about 60 minutes to pull it all apart, reseat all the connectors, and get it back together. The new HD is recognized, and Leopard is installing.

While I was in there I had the idea to hardwire in a tiny Bluetooth 2.0 EDR USB dongle I had directly to one of the USB ports. Lost that port to external use, but I never use them anyway.