PDA

View Full Version : ad hoc networks: how to delete it?




gioking
May 17, 2008, 02:19 PM
Ad hoc network: how to delete it? Help pls!

I'm a new owner of a Mac mini (I hope the problem is related to this..:) )and I have an incredible problem.

By mistake I created a C2C network (i did it to connect the mini to my printer; all worked fine).
two days after I buyed a time capsule..I installed and configure it (connecting to it both by cable and wireless), and made the first backup too.Of course I created a new wireless network on the Time capsule and made it the center of my environment.

then sudden the problem: the mini always switchs by itself to the old C2C netw and if, and everytime, I go to change network (trying to connect to the new one on the time capsule) he doesn't allow me to connect...(the mini sees it correctly but fails to connect)

I tryed everything (network and airport utilities, controlling address, heys etc)..nothing.

After hours I discovered this: It is possible to reconnect to the "good" network just if, on the mini, I stop the airport, create a new adhoc network and then I switch to it.
the problem is that the old C2Cnetwork is still there and everytime the mini switches back to it.

guys I'm frustrated and on the limit of the delusion....anyone that can help ?

thank you very much

PS: the time capsule config is perfect(PCs, PS3,xbox etc..all connected it



MacDaddy08
May 19, 2008, 06:18 PM
I'm going to try and take a crack at this. It sounds like the C2C network is still on your "preferred networks" list. So your computer is automatically connecting to it. I would try removing it from the "preferred networks" list and see if that solves your problem.

Procedure:

1. Click on the airport icon at the top of the screen and click "open network preferences"
or
Click on system preferences and then click "network"

2. Click on airport under network preferences and then click advanced

3. Under the advanced menu there should be a tab for airport, click on it if it isnt currently highlighted

4. You will see a list of preferred networks, highlight the C2C network and click the minus sign to delete it from the list.

5. Click OK and then Apply on the network preferences window.

I hope that solves your problem, that is all I can think of.

brett_x
May 20, 2008, 12:40 PM
I had the same issue. I reported it as a security bug to Apple, because once I created the ad hoc network from one machine, I couldn't kill it no matter what I did. Their reply was this:

It sounds like you had two computers participating in an IBSS
network. If that is the case, the network will not go away until both
machines cease participation. Both machines share responsibility for
sending beacons and probe responses. If the machine that originally
creates the IBSS goes away, the network still lives on with the
second machine.


Hope that helps.

gioking
May 24, 2008, 11:37 AM
thankyou for the support. to both. unfortunately the C2C network is not shown in the preferred network.

related to the answer given from Apple, in my case I must tell it's entirely a MiniMac (or leopard) sw failure.
In this case the other "responsible" system is my printer, no longer connected to that network (and often switched off).

I think the problem is related to the fact that the scientists of Apple allowed this happen easily.
Infact when you create a Network, the system proposes to nominate the network using the same name of the machine ("Mac mini di Giovanni", in my case). Probably this is at the base of the problem.

I'm looking to find a system file with all the network (wireless or not) preferences.

Meanwhile I cancelled the Airport driver (better to think I don't have any of it) and I'm using a cable to connect the mini to the Time capsule...incredible .

Of course the credibility of Apple (just to my opinion, of course) it's dramatically fallen and I'm back on my windows laptop...But I'll keep fighting back ;-)

Hickeroar
Apr 8, 2009, 07:49 AM
I just had this issue as well. I fixed it by disabling airport and re-enabling it. The ad-hoc network disappeared.

EDIT: Correction... It disappeared for a few minutes and then just magically re-appeared.

EDIT #2: Wow, now it's gone again. carazy!