PDA

View Full Version : Orphaned Tracks with an ! next to 'em




hualon
May 22, 2008, 11:31 PM
I made a video smart playlist today to show me movies that I've never watched. It just happened to catch a bunch of podcasts that I either A) no longer subscribe to and/or B) don't even exist on the drive.

All of them have exclamation points next to them BUT since they're in a playlist, I can't delete them from the database.

So since these are orphaned PODCASTS and I don't subscribe to them anymore, they don't appear as items in my Library under Podcasts, let alone any other heading (Movies, Music, TV Shows, etc.)

So how can I purge these things from my database?!? There are lots of them.



alphaod
May 23, 2008, 12:17 AM
Have you tried right click "Show in Playlist-->"?

hualon
May 23, 2008, 12:47 AM
Have you tried right click "Show in Playlist-->"?

Well I just did and they show up in one other playlist... so what?

alphaod
May 23, 2008, 12:52 AM
Well I just did and they show up in one other playlist... so what?

Well it should show up in the Videos playlist where you can delete it? The only other thing I can suggest is to delete your iTunes library index and re-add everything.

hualon
May 23, 2008, 12:54 AM
Well it should show up in the Videos playlist where you can delete it? The only other thing I can suggest is to delete your iTunes library index and re-add everything.

That's the problem. It ONLY shows in the playlists and not in the library anywhere! I can't *find* these things except in a playlist.

Cinematographer
May 23, 2008, 02:27 AM
If they are in a playlist, they have to be in the library too. Either in Music, Film, Podcasts or whatever.

alphaod made a good suggestion: Right-click on one of the tracks and click on "Show in Playlist". If the track is listed in other playlists, these show up with a generic blue icon. But on the top, one of the top level library parts should show up, "Podcasts" in your case (with a colored icon). Click on it, and it will bring you to the window where you can delete the file.

If it doesn't work, go to Preferences -> first Tab: General and check the box next to Podcasts. Then try again.

hualon
May 23, 2008, 09:27 AM
If they are in a playlist, they have to be in the library too. Either in Music, Film, Podcasts or whatever.

alphaod made a good suggestion: Right-click on one of the tracks and click on "Show in Playlist". If the track is listed in other playlists, these show up with a generic blue icon. But on the top, one of the top level library parts should show up, "Podcasts" in your case (with a colored icon). Click on it, and it will bring you to the window where you can delete the file.

If it doesn't work, go to Preferences -> first Tab: General and check the box next to Podcasts. Then try again.

They are NOT in the the podcasts, movies, music or audiobooks categories in the Library. If I right-click on the items and select "Show in Playlist", the ONLY thing that shows up is the other playlist that they're in. There's nothing on top showing the top level library.

The Podcasts box is already checked. The only thing that I have unchecked there is iPod Games.

reubs
May 23, 2008, 09:48 AM
Try this script.

http://dougscripts.com/itunes/scripts/ss.php?sp=removedeadsuper

alphaod
May 23, 2008, 07:24 PM
Try this script.

http://dougscripts.com/itunes/scripts/ss.php?sp=removedeadsuper

Impressive software there. Very nifty.