PDA

View Full Version : DNS Question




matt321
May 23, 2008, 04:26 PM
Hi folks,

I just purchased OS X Server 10.5 and have been messing around with it. I have run into a few issues.

-I setup OS X server and add users.

-I go to a client machine, iMac with 10.5, and use Directory Utility to connect.

-I reboot the client machine and it appears to authenticate.


I do all this and it does not retain it's credentials and will not use it's time machine backup...

Also, the group calendar does not update across computers...

Am I missing something? Is this a DNS issue?


Thanks!



rickgmac
May 27, 2008, 07:50 AM
Which config are you using, standard, workgroup or advanced?

yellow
May 27, 2008, 08:04 AM
Who is doing your DNS? Your Server?

MacsRgr8
May 27, 2008, 05:01 PM
Eh.. whoa...

Just a few simple steps for making a working OD structure in Leopard Sever:

1) Examine your current network.
- Is there a DNS already present?
- Is your IP range known?
- Is there a DHCP server in your network?

2) Answer your own questions:
- Of no DNS is setup, make your server the DNS sever.
- If there is a DNS server setup, make sure your new server gets an IP address with reverse lookup DNS entry
- Configure the IP range.
- Setup DHCP, but not if there is a DHCP server already present!

3) Setup and config your sever:
- Use the current DNS server for you hostname setup, or;
- Setup DNS
- Setup DHCP if necessary
- Then setup Open Directory Master (recheck DNS reverse lookup by examining Kerberos realm)

4) Setup clients:
- Make sure that the IP setting is correct (either using DHCP or manual)
- Connect to OD master using "Directory Utility"

Have fun! :)