PDA

View Full Version : Leopard Server & Permissions issues




bigandy
Jun 2, 2008, 10:18 AM
I have an issue with a G5 Xserve running 10.5.2 Server.

There are around 15 users with accounts connected to this particular box. All of them have an installation of Mac OS X 10.5.2 client, and use both Windows (via Parallels) and OS X to access files within the Public folder structure on the Server.

It seems that permissions keep on changing once they're created. Sometimes seemingly randomly.

How can I force the server to ensure that any files or folders created within the Public folder or subfolders are *always* created 777, rwxrwxrwx, or full access for all?



bloggerblog
Jun 2, 2008, 05:17 PM
I wouldn't recommend upgrading to OSX Server 10.5.x unless this problem is properly addressed by Apple. One solution could be creating a Folder Action or an Applescript, to propagate permissions.

Sayer
Jun 2, 2008, 07:36 PM
Assign all users to the same group, make that group owner of the root Public folder, use ACLs, train your users on how to use their computers to store files on a public share.

Pick any two or three.

Buy a SAN appliance.

bloggerblog
Jun 3, 2008, 09:12 AM
I'm curious, did anyone try osx server 10.5.3 yet? If so does it fix these problems?

bigandy
Jun 3, 2008, 10:59 AM
I wouldn't recommend upgrading to OSX Server 10.5.x unless this problem is properly addressed by Apple.
It's on 10.5.2 at the moment, so that doesn't really help ;)

One solution could be creating a Folder Action or an Applescript, to propagate permissions.
I was thinking of doing that - but will it propagate to subfolders properly?

I've never used folder actions - could I use them to run a shell script which recursively resets permissions, or could it catch the file that's been modified and alter that?

Assign all users to the same group, make that group owner of the root Public folder, use ACLs, train your users on how to use their computers to store files on a public share.

Pick any two or three.

Buy a SAN appliance.
Actually that group/ACL is in place on the Public folder currently. Why should the users do differently as they do now, which is creating documents and folders in the same way as they would a local file or folder? *mumbles to self, 'never had this issue with windows networks'* :rolleyes:

I'm curious, did anyone try osx server 10.5.3 yet? If so does it fix these problems?
It mentions permissions issues have been addressed, so I'll be updating before kicking off this evening... After a complete backup run, of course ;)