PDA

View Full Version : YouTube Laggy




BoulderBum
Jun 3, 2008, 11:47 AM
Does anyone ever have trouble playing YouTube on the Apple TV (and their computer for that matter)?

All the bandwidth tests say I have ample bandwidth (up to 22 Mbps) at the time I experience the lag issues, but for some reason it seems like the Apple TV is always pausing and playing catch-up.



Kilamite
Jun 3, 2008, 01:12 PM
Does your Apple TV buffer the YouTube video or does it play right away?

gkarris
Jun 3, 2008, 01:24 PM
Make sure you're on the latest software release and that, if it is cable, you are really sharing the bandwidth with others. If on wireless, make sure you are getting the max signal.

BoulderBum
Jun 3, 2008, 05:14 PM
Does your Apple TV buffer the YouTube video or does it play right away?

It buffers, takes a long time to do so, and ends up lagging/pausing anyway.

Make sure you're on the latest software release and that, if it is cable, you are really sharing the bandwidth with others. If on wireless, make sure you are getting the max signal.

Software is updated as of only a month ago (2.1 is it?), and I'm connecting wireless N at 130 Mbps, 100% signal strength. Interestingly, HD podcasts streamed from the internet tend to play instantly as do movie rentals. It seems like it's not a bandwidth issue!

Kilamite
Jun 3, 2008, 06:15 PM
Software is updated as of only a month ago (2.1 is it?), and I'm connecting wireless N at 130 Mbps, 100% signal strength. Interestingly, HD podcasts streamed from the internet tend to play instantly as do movie rentals. It seems like it's not a bandwidth issue!

2.0.2 is the latest - came out just over a month ago so you'll be up to date.

I did have YouTube problems with some videos, but most of that got fixed with 2.0.2. Is it all videos that lag or just some?

BoulderBum
Jun 4, 2008, 02:38 AM
2.0.2 is the latest - came out just over a month ago so you'll be up to date.

I did have YouTube problems with some videos, but most of that got fixed with 2.0.2. Is it all videos that lag or just some?


It seems to happen with all videos, though once in a blue moon, it streams as fast as I'd expect. What's weird is that I see the same problem with my PC and YouTube, but no other video sites, even if they use a flash-based player.

Kilamite
Jun 4, 2008, 07:06 AM
So the problem isn't really down to the Apple TV, same happens to your PC?

What router are you using?

BoulderBum
Jun 9, 2008, 11:51 AM
I have a D-Link DIR-655 "Xtreme N" router. I sort of wondered if the QoS might be screwing something up, but it's odd that it happens only with YouTube, not other video sites (and I discovered it doesn't always happen).

Yes, btw, it does seem to happen on my PC, too, though it seems that longer YouTube videos get an error on Apple TV. It's something about "Apple TV can't play this format" or something like that.

droalex
Jun 9, 2008, 07:43 PM
It may be your internet speed.

BoulderBum
Jun 10, 2008, 11:03 AM
It may be your internet speed.

I mentioned earlier, but I'm getting bandwidth tests indicating 22 mbps at the same time I'm having YouTube lagginess.

It seems unlikely that the bandwidth is the issue.

adrianseto
Jun 10, 2008, 11:54 PM
I have the same buffering issues with Youtube on ATV. And when I try to view the same video on my PB its fine. I think its the delivery to ATV from Youtube that is faulty. Youtube may have to deliver a higher res version to ATV as opposed to what plays directly off their site? Just a thought...