PDA

View Full Version : apple tv connected to router but not internet




redgaz26
Jun 11, 2008, 10:56 AM
my dad's apple tv is not connecting to the internet, on the settings page it says the router is connected but also says theres not router ip address. both my iphone and my mums mac both connect and can get online with the router, any clues as in what to do with the :apple:tv??



hotzenplotz
Jun 11, 2008, 10:57 AM
Is the network setup as DHCP or static IP?

redgaz26
Jun 11, 2008, 11:16 AM
ok im no expert with this stuff so i took a pic on me iphone

hotzenplotz
Jun 11, 2008, 11:32 AM
No router or DNS address, so it looks like your network is setup as static IP. Look on one of your computers, under network settings, what it supposed to look like and go from there.

hmmfe
Jun 11, 2008, 11:50 AM
You've got a few problems...

1) 169.254.x.x as an IP address means you are not getting an IP address from you DHCP server.

2) No default gateway/route (router IP). Without this, no routing so no internet.

3) No DNS. If you try to connect to anything by name (e.g. www.macrumors.com) instead of IP address - you won't be able to resolve the name.

It all seems to stem from the fact you can't get to your DHCP server. I'd try to static the address using known information from a computer that is connected. Just copy the information and *turn off or disconnect* the computer you used to get the settings. If that works, then you know there is not a basic issue with connectivity or the AppleTV.

Next, you'll either have to fix the DHCP issues or just static the AppleTV using an available address within your subnet.

redgaz26
Jun 11, 2008, 11:59 AM
ok so I go into the settings via my mums mac and put in the routers ip and and such like, then turn then restart the mac and see what happens??
as i say i'm no expert with this so will report back thanks guys

hotzenplotz
Jun 11, 2008, 01:50 PM
Go to your mums Mac and go to:
Apple Menu > System Preferences... > Network

Make sure that "Built-in Ethernet" is selected in the left pane. If the pull-down under "Configure:" says Using DHCP, write down the following:

IP Address: (for example 10.0.1.20)
Subnet Mask: (should be 255.255.255.0)
Router: (example 10.0.1.1)
DNS Server: (<---there should be two addresses, i.e. 12.34.56.78, 98.76.54.32)

If you have additional computers in your house, check their IP addresses as well, as to not assign the same IP address twice; see below.

Go to the ATVs network settings and type all the information in like above, except the IP Address - Increase this one by one, i.e. 10.0.1.21.

sneeks
Jun 12, 2008, 05:21 AM
All good advice but I'd recommend you firstly shut down the modem/router and Apple TV then restart each in turn beginning with the modem/router. This may well reset the settings.

srtk81
Jan 18, 2011, 10:35 AM
Hi, I am having the same problem, were you ever able to fix this?

Tilpots
Jan 18, 2011, 10:45 AM
Hi, I am having the same problem, were you ever able to fix this?

I'm guessing your talking about the ATV2?

Try unplugging the ATV2's power cord and your ethernet cable. Then plug the ethernet cable back in and next plug your ATV2 power cord back in. This should fix your problem, I hope...

tippman
Jan 18, 2011, 01:50 PM
Hi

I'm having the same problems. When I try to install ATV2 the settings page says itís connected to my network but not to the internet. On the settings page this is showing:

IP Address: DHCP 169.254.206.106
Subnet Mask: 255.255.0.0
Router Address: N/A
DNS Address: N/A

Signal Strength is good and shows all the bars.

I have a basic ATT DSL Router/Modem Ė 2Wire 2701HG-B. I have an iPhone and iPad and they connect to the internet with no problem. Iíve tried resetting the modem/router but this doesnít work. These are their network settings:

iPhone
IP 172.16.1.35
Subnet mask 255.255.0.0
Router 172.16.0.1
DNS 172.16.0.1

iPad
IP 172.16.1.33
Subnet 255.255.0.0
Router 172.16.0.1
DNS 172.16.0.1

My father-in-law lives a floor below me so I tried to see if I could get on his wireless network. I had no problem getting the ATV2 to connect to the internet -these are my network settings on his network:

IP Address: DHCP 192.168.6.108
Subnet Mask: 255.255.255.0
Router Address: 192.168.6.1
DNS Address: 68.94.156.1

I'm using WEP for security. Looks like I'm having issues getting a DHCP address. Can anyone please help?

ehurdler
Jan 18, 2011, 02:06 PM
Do you have another available address on your wireless network for the aTV2 to grab? May want to turn wireless off on your iphone for example, go into the wireless router and release/renew the leases it has given out. The aTV may grab the unused IP. Course you can always see if you can bump up the allowed clients to be connected.

Hammie
Jan 18, 2011, 10:19 PM
Hi

I'm having the same problems. When I try to install ATV2 the settings page says itís connected to my network but not to the internet. On the settings page this is showing:

IP Address: DHCP 169.254.206.106
Subnet Mask: 255.255.0.0
Router Address: N/A
DNS Address: N/A

Signal Strength is good and shows all the bars.

I have a basic ATT DSL Router/Modem Ė 2Wire 2701HG-B. I have an iPhone and iPad and they connect to the internet with no problem. Iíve tried resetting the modem/router but this doesnít work. These are their network settings:

iPhone
IP 172.16.1.35
Subnet mask 255.255.0.0
Router 172.16.0.1
DNS 172.16.0.1

iPad
IP 172.16.1.33
Subnet 255.255.0.0
Router 172.16.0.1
DNS 172.16.0.1

My father-in-law lives a floor below me so I tried to see if I could get on his wireless network. I had no problem getting the ATV2 to connect to the internet -these are my network settings on his network:

IP Address: DHCP 192.168.6.108
Subnet Mask: 255.255.255.0
Router Address: 192.168.6.1
DNS Address: 68.94.156.1

I'm using WEP for security. Looks like I'm having issues getting a DHCP address. Can anyone please help?

A couple things. Whoever set up your network obviously changed things from the typical default 192.168.x.x network. Therefore, these two options can be considered.

1) see if MAC address filtering is on or off. If on, you will need to add the ATV2 MAC address into your allow list.
2) add the ATV2 using a static address. I do not have DHCP turned on my network, so I know the ATV2 can be added statically.

On of these two things should resolve your issue.

tippman
Jan 19, 2011, 09:30 AM
Thanks for your reply hammie. Unfortunately I don't know how to do the 2 things you suggested. Can you please walk me through it?

Hammie
Jan 22, 2011, 08:19 AM
Thanks for your reply hammie. Unfortunately I don't know how to do the 2 things you suggested. Can you please walk me through it?

The easiest of the two is to add a static IP address to your ATV2.

You will need to go to Settings > General > Network

You should be able to assign it the following information:

IP 172.16.1.50 (I picked number this randomly. You technically can use any number between 172.16.0.2 and 172.16.255.254, minus any ones already used.)
Subnet 255.255.0.0
Router 172.16.0.1
DNS 172.168.0.1

This should work since based on your answer, I doubt that MAC Address filtering is turned on.

BTW, sorry for not getting back to you sooner. Hope I did not hold you up and this has been working for the past few days.

fsron
Jan 22, 2011, 09:10 PM
I'm probably going to fumble this a bit since wireless security is way over me, but I ran into this yesterday and fixed it. I took my ATV 2 over to a friends house and we got the same error. He was also using WEP security. The WEP security in his wireless router generated a WEP key from his pass phrase. When we entered the pass phrase in as the pass word on the ATV 2, the ATV 2 said it connected to the network, but not the internet.

After a while we finally entered the WEP key instead of the pass phrase and it worked. If your wireless router has generated a WEP key make sure you use that.

Stubaan
Jun 19, 2013, 11:15 PM
Hi folks

I have an aTV 2 that quit its connection with the internet in the middle of a show last week, and has never been able to reconnect. All I can get with resets and restores is the Computers and Settings icons, as has been reported in similar connectivity cases. The factory restore I did by connecting the aTV directly to my Mac and doing it that way. Without connectivity the aTV could not download the latest software and would not go through with a restore command originating directly from the aTV menu itself.

I have followed the advice further up this thread and input addresses for my network manually, based on my iPhone's specs:

IP: 192.168.11.39
Subnet: 255.255.255.0
Router: 192.168.11.1
DNS: 192.168.11.1

For the aTV IP address I randomly changed the last number from 39 to 41, and when that didn't work to 68, which still didn't work.

My wireless network at home is working fine because I'm able to access it via iPhone and MBP, but it no longer ever appears as an option on the aTV, whether I physically disconnect the Ethernet cable or not. This was not the case previously.

Though a Windows laptop had no trouble at all connecting to the Internet using the aTV Ethernet cable, when I try to on my MBP I instead find myself redirected an old page from my university's CNS department telling me I have been redirected there because I am using a retired DNS server. I say old because it refers to upgrades to our campus wide network that were finalized in March or April.

In fact, the above mentioned "retired DNS server" page has now reared its ugly head twice. A couple of weeks ago I suddenly found myself relegated to this page, and ended up switching out to a new modem. Though my buddy and his Windows laptop again had no trouble connecting by Ethernet, I could not with my MBP, and at the time not wirelessly either. But then it suddenly all started working again.

Suggestions. Please. This is so frustrating.