PDA

View Full Version : Simple Question




quicksilver77
Jun 20, 2008, 07:06 AM
I backed up all my music from my iMac on my external drive. Meaning I manually copied the iTunes Music folder and the .xml file to the WD passport drive. I then connected it to my MBP and changed the location in preferences and pointed to the WD Passport:iTunesMusic Folder.

I have waited 10 minutes and nothing is showing up in iTunes. No song titles...nothing. Do I need to do something with the XML file? I thought iTunes would just build the library database file after I changed the location for my music to the external drive. What step am I missing? I do not have enough space on MBP hence using the external drive.

Thanks



Mitthrawnuruodo
Jun 20, 2008, 07:17 AM
It's not that simple, I think.

You need to replace the iTunes Library file (http://support.apple.com/kb/HT1660) on your MBP with the one from your iMac (preferably after moving the contents of the library correctly (http://support.apple.com/kb/HT1449?viewlocale=en_US) from the iMac to the external).

quicksilver77
Jun 20, 2008, 07:31 AM
What if I change the library location to the external drive. Then uncheck copy songs to itunes library when playing. After that I click Import and choose the library on the external drive. That should rebuild the XML database file using the external HD as the source?

henchosbandito
Jun 20, 2008, 08:06 AM
from my experience, even though you have changed the location in iTunes, this is usually only where it write music to when you import your music. You need to go File, Add Folder to Library and select the folder with all your music in. Then, all your music will appear