PDA

View Full Version : 1GB Nano Stuck On Hold; Hold Switch Removed From Board




Haselsmasher
Jun 22, 2008, 07:14 PM
My son dropped his Nano and it got stuck on hold. No amount of moving of the physical switch took it off hold. One of the results (in addition to making the click wheel ineffective since it was "locked") was that we couldn't do a reset - since the reset sequence starts with putting the unit on hold and then taking it off. :-(

So - I took the unit apart. Manually moving the hold switch made no difference. So the issue clearly was an electrical/contact problem.

The switch was loose. 2 of the 5 places where the switch attaches to the main board were knocked loose. Of these 5 attach points I'm not sure if all 5 are electrical connections - or some are electrical and some are just for physical connection of the switch to the board.

The 5 attach points look like this:

*_________________*
_____*_____*____*

To ease the discussion I'll number them:
1_________________5
____2_____3____4

(Try to ignore the underlines. It's the best I could do to get the spacing I wanted.) The '1' attach point is on the edge of the board. This is side the Hold switch would be on if the unit was *NOT* on hold.)

In another (non-macforum) page I found reference to this problem. It said solder together with wire "the two contacts on the left". I did some experimenting and when I shorted 2/3 together the screen would light up. I ended up taking a tiny piece of aluminum foil and laying it across 2/3, used nail polish to hold it in place, and reassembled it.

The unit is still stuck on hold. Does anyone happen to know exactly which points I need to connect to get it off hold? I know whatever I do will cause this unit to be off hold permanently. (I guess I could try resoldering on the whole switch. But the switch itself might be bad.)

Thanks, and sorry for the long post.

Jim