PDA

View Full Version : Wifi on Touch: Why can I only access Google?




camillei
Jun 29, 2008, 01:58 PM
I really hope someone can help me out!

I don't have a wireless network at home so I followed the instructions in this video: http://www.cnettv.com/9742-1_53-28619.html (Similar instructions at this page : http://ahtim.com/poor-man-cheapest-wifi-router/) to set up my laptop as a wireless hotspot.

My iPod Touch detects the network, but won't let me connect. When I open Safari, I can access all the bookmarked stuff like the Apple page, Google search, gmail and google reader, but not anything else. For example, if I go into my gmail, open up an email from say, Facebook and click on the link, it says Safari can't connect to the network or something.

I've tried all kinds of troubleshooting but I can't seem to find mention of a similar problem anywhere else on the variety of Touch-related forums I've visited. Can anyone help?

Camille



linden
Jun 29, 2008, 02:20 PM
Thats odd. Have you tried restoring?

mkrishnan
Jun 29, 2008, 02:37 PM
Based on the link you provided... the notebook that is sharing the net connection is a Windows notebook, right? The Windows experience here is variable... can you start by providing more details -- which version of Windows you use, in particular? It sounds like the problem is either at the step where the network is specified as ad hoc, or at the step where the internet connection is being shared by the notebook.

One thing that would help is, after you go through all this and you are able to access Google on the iPod but nothing else, what does the iPod think its IP Address is? You can get this by selecting the SSID of your ad hoc connection from the list on the iPod, and then it should list an IP address in the info page. If the address is not of the form 10.0.1.x or 192.168.1.x, your notebook is not allowing the iPod to get an address via DHCP. If it is of one of those forms and it doesn't work, then it's allowed the iPod to get an IP address from it, but it isn't giving it network access....

camillei
Jun 29, 2008, 05:46 PM
My laptop is running Windows XP, yeah.

So, I restored my iPod and tried again, and I had the same problem, so I don't think that was the cause.

Also, I checked the IP address like you said, mkhrishnan, and it was indeed 192.168 something something. Right after I did that I tried using Safari again, and it let me open gmail and then follow a link to the login page for facebook, but the wifi icon at the top left disappeared and the connection didn't work after that. I'm starting to think it's a problem on the computer's side rather than on the ipod's side, could that be right?

Also, this might just be something I don't understand about ad-hoc networks, but the computer itself detects the network in its list of available wireless networks, but will only connect to it when the iPod tries to connect to it. Does that make sense? I'll enter the WEP key on the computer and it'll say "Not connected" (but with the option to Disconnect, so it must be connected in some way??) and then as soon as I try to access the network through the iPod, it will connect and say Signal Strength: Excellent.

On top of all that, the only other device I can test the network on is another iPod touch, and it doesn't work on that one either, I don't know if that's helpful information.

Thanks for your help, I'll keep fiddling around with it. Let me know if you have any tips.

shaund
Jun 29, 2008, 06:30 PM
Here ya go. (http://www.ipodtouchfans.com/forums/showthread.php?t=42331)

I had the same problem with mine, and this did the trick.

davidy
Jun 29, 2008, 10:47 PM
Do I understand this right? You can use your laptop as a wireless router? In order for this to work there would have to be a transmitter in the laptop. Is there one?

mkrishnan
Jun 30, 2008, 06:39 AM
Do I understand this right? You can use your laptop as a wireless router? In order for this to work there would have to be a transmitter in the laptop. Is there one?

You can use pretty much any notebook with a wifi adapter as a router, with some limitations. Almost all wifi cards -- certainly any recent card -- can operate in this mode. The requirement is just that the computer must obtain its internet / WAN connection using something else other than wireless -- e.g. ethernet.

OS X, Windows and Linux (at least Gnome variants) all have this feature in a fairly easy to use setup. It's not great, though, and in most cases one will want to just pay the $25 and get a router....

camillei
Jun 30, 2008, 09:51 PM
I've tried a few things and it's still not working. The wifi icon is there, but it just doesn't work. I hadn't thought of this before, but I think it might have something to do with the fact that my house's internet connection runs on a network server? (My parents have a home office)

I'll have to find a wireless hotspot to really test it out, and check that it's not a problem with the ipod. And then, I guess I'll wait til I move back to school next fall so I can use the free campus wifi, that should work no problem. Thanks for your help!