PDA

View Full Version : Quirky iTunes & Apple TV Sync or Something Else?




nittany
Jun 30, 2008, 09:22 PM
Maybe everyone else has already figured this out, but...

First, my iTunes setup is pretty simple:

All of the content (movies, music, TV shows, photos) that I wish to make available to my :apple:TV resides on drives that are external to the Mac that runs the instance of iTunes that is paired with the :apple:TV.

My content is not copied to the iTunes Music folder.

The :apple:TV device's summary tab shows the Custom Sync option as being selected. The Movies, TV Shows, Music and Podcasts tabs do not have the Sync option selected; however, the Photos tabs shows that the photos are to be synced with a single folder (with nested subfolders) that is also resident on one of the external drives.

I run the most current version of iTunes - currently it's 7.6.2 (9).

My Mac setup is equally simple:

Intel Mac Mini (purchased new in November of last year) with whatever is the most current version of OS X - currently 10.5.4.

My :apple:TV setup is:

One 40GB stock unit running the most current version of the Take 2 software.

The quirkiness:

1) Although the Mini generally remains up and running 24x7, whenever iTunes is closed, the next time it is opened, it would appear (I have no way of knowing what it is really doing) that each song, movie, etc. is somehow being re-connected. Why do I think this is the case? Because for nearly 5 minutes, iTunes is frozen from accepting my input commands and the hard disks on which the content is located begin to operate continuously (observed via sounds and activity lights). Why does this happen? Is it a quirk of iTunes? I don't think so because when another of my Macs initiates iTunes, the same results don't occur - even though the same content is being accessed (although resident on other drives that are internal to the machine). To me, the Mac Mini's results seem a lot like the problem that was inherent in an older version to iTunes (maybe way back to 7.3), where starting the application would cause it to spend a lot of time re-establishing the connections with the content. Anyone have any ideas?

2) Sometimes when iTunes is closed (as it was this evening when the Mini needed to re-boot to initiate OS X 10.5.4), the sync option in the Photos tab in iTunes somehow gets de-selected and some iPhoto folder shows as being the default item. If I re-select the sync option, the correct folder on the correct external drive shows as ready to be selected from the drop-down list, but in doing so, the next time iTunes syncs with the :apple:TV, the photos resident on the :apple:TV are wiped and the same photos are re-synced back to the :apple:TV. Any one have any ideas?

Other than these quirks, I've not had any problems with my setup. It just seems odd that this is happening. is it just my setup or does anyone else have the same or similar issues?



MikieMikie
Jul 1, 2008, 08:25 AM
I had the same behavior when I was handing an External HDD off of my AEBS (aka AirDisk). Any chance your external drives are hanging off of there instead of directly connected to your mini?

nittany
Jul 1, 2008, 08:41 AM
I had the same behavior when I was handing an External HDD off of my AEBS (aka AirDisk). Any chance your external drives are hanging off of there instead of directly connected to your mini?

Not a chance. The storage is directly attached to the Mini.

pagansoul
Jul 2, 2008, 06:44 AM
I have a MacPro as my main computer. My iTunes have their own 500GB drive for music but my video also has their own 1TB drive. I use the control link between my movies and iTunes. My :apple:TV is set to only download checked items so some movies are on its 160GB HD and some music. If my itunes is off, or my computer is tuned off, I still have about 100GB used space on :apple:TV of music favorites (about 1000 songs) and a impressive amount of video (about 20 movies, entire Blue Planet, many shorts (Aeon Flux, Creature Comfort, Invader Zim collections)) and music videos. When iTuns is on I can stream over 300 of my ripped movies. I have the latest firmware and have no problems with syncing, my problems all come with trying to hook up my internet connection with Comcast. I can get my computer working but not my network. I've moved stuff around a hundred times, sometimes it works, sometimes it doesn't. I wish I knew the right formula. :o