PDA

View Full Version : Submitting an iPhone App to the App Store




Littleodie914
Jul 2, 2008, 07:14 PM
Hey guys, I'm having trouble submitting my application to the App Store. The distribution provisioning profile in my developer portal has the "download" button next to it, but it's grayed-out? I checked the HTML, and the image is called something like "download_button_inactive.jpg".

Is anyone else having this problem? Know of a fix, or something I'm missing? Thanks!! :)



tacoman667
Jul 2, 2008, 08:33 PM
Hey guys, I'm having trouble submitting my application to the App Store. The distribution provisioning profile in my developer portal has the "download" button next to it, but it's grayed-out? I checked the HTML, and the image is called something like "download_button_inactive.jpg".

Is anyone else having this problem? Know of a fix, or something I'm missing? Thanks!! :)

You need to make sure that you have recreated the AppID and re provisioned your application to a device if this was done before June 7 or 9, I can't remember. Have you done that already?

Littleodie914
Jul 3, 2008, 06:01 AM
You need to make sure that you have recreated the AppID and re provisioned your application to a device if this was done before June 7 or 9, I can't remember. Have you done that already?Nope, I hadn't, and that was the problem. :) Thanks!

Also, to anyone else having trouble finding their iPhone Distribution Provisioning Profile in Xcode, once you're trying to configure your distribution build, make sure that you set all that code signing information on the "target" itself, and not the overall project. That had me stumped for a while. :D