PDA

View Full Version : Trying to setup a simple FTP server using Leopard




teluguman
Jul 3, 2008, 09:23 PM
Hi guys,

So I've been slowly tinkering with various configs to get my mac to share files on my computer through an FTP server, which others can access by using an FTP client on their end and logging into my computer. (Also could potentially be useful for me if I'm away.)

In any case, what I have is Leopard on a mbp, wirelessly connected to a d-link router, connected directly to a PC (yuck hehe) home computer. I have generated a static IP address for my mbp (192.168.0.101) and have checked to make sure that it is open (2 ways: one, my torrent clients, transmission and vuze have both said the port is open, and two, dyndns online says it's open to traffic). The port I'm using is 49999. I have this port forwarded to my mbp's private IP (192.168.0.101) under the Virtual Servers section of the d-link config settings. I also have a password for my mbp user account, which I would give to the person who I would want to have access my files. I also have installed dyndns updater and have selected a xyz.homeftp.net address to be assigned to my computer's web-based IP address. I have FTP sharing access "on" under "sharing" in system preferences.

However, I can not access my files through an FTP client (cyberduck) on my mac, nor using a diff. client on the PC. I am inputing the server as the xyz.homeftp.net server, with the port as 49999, and the correct username and password.

I have no idea what I'm missing. I haven't had this work once yet, so I'm hoping you guys can help me get this up and running.

Let me know what other information you need, if any.

Thanks!



loveturtle
Jul 6, 2008, 11:25 PM
because ftpd is probably listening on port 21 and you forwarded port 49999 or whatever. In the forwarding rule it should forward external ip 49999 to port 21 on local ip, or change ftpd to listen on that port.

teluguman
Jul 7, 2008, 11:10 PM
Got it!

Great, thanks. Basically, I had to not use 49999 as the FTP port, but instead forward port 21 straight to my computer (through my router).

But, I would definitely like to know how to change the fact that my mac shares its files through FTP on port 21. What if I want it to share on a different port, where do I change that?

Thanks a lot.