PDA

View Full Version : Any way of disabling Exchange password lock requirement




Riemann Zeta
Jul 10, 2008, 01:15 PM
One of the features of OS 2.0 that I have been waiting for is exchange support. However, now that it is here, it is more annoying than simply using Safari and webmail. That is, when I set up the Mail app for an exchange server, it requires that I have a passcode lock on my phone and this setting cannot be altered. Hence, every single time I turn the phone on--say, to skip to a particular track I want to hear--I have to fumble with numeric codes, instead of using the oh-so-useful "slide to unlock" feature. Anyone know of any way to (or an App that can) disable the forced password "feature."



kam61799
Jul 11, 2008, 07:13 PM
I too would love to find out if there is a way to do this.

matperk
Jul 12, 2008, 12:07 AM
One of the features of OS 2.0 that I have been waiting for is exchange support. However, now that it is here, it is more annoying than simply using Safari and webmail. That is, when I set up the Mail app for an exchange server, it requires that I have a passcode lock on my phone and this setting cannot be altered. Hence, every single time I turn the phone on--say, to skip to a particular track I want to hear--I have to fumble with numeric codes, instead of using the oh-so-useful "slide to unlock" feature. Anyone know of any way to (or an App that can) disable the forced password "feature."

This is part of exchange policy features on the phone that makes it good for enterprise, there WILL BE NO way around this merely because if there was it wouldn't be a secure phone in the minds of corporations and wouldn't be adopted.

To help solve your problem though, while it's off, can you double click the home button and bring up a small music controller?

andykass
Jul 12, 2008, 06:10 AM
I too have the same issue, and it's pretty annoying, however there is a iPhone configuration utility(mac only) where you can setup a profile which you can install by emailling the profile to you phone, open the mail and install. It allows you to select that passcodes are not required....BUT after installing I still can't seem to switch it off.

http://www.apple.com/support/iphone/enterprise/

Anyone managed to get this to work? Or is it hardcoded that exchange == passcode.

still love the phone though....

cualexander
Jul 12, 2008, 08:57 AM
This policy must be set by your enterprise IT administrator. Because I have exchange on my iphone and I swear that I have no password lock whatsoever. So I don't think it is the fault of the iphone more its probably the fault of some security setting in exchange. I wouldn't blame Apple on this one.

andykass
Jul 12, 2008, 10:46 AM
I use 1&1 hosted exchange mail account, so they must have their policy set. Unlikey to change I would think :(

JonboyDC
Jul 12, 2008, 11:04 AM
This is part of exchange policy features on the phone that makes it good for enterprise, there WILL BE NO way around this merely because if there was it wouldn't be a secure phone in the minds of corporations and wouldn't be adopted.
I'm sure this is true in many companies, but not all. My firm certainly doesn't make us enter passwords on our Blackberries every time we turn it on or unlock it. I hope I won't have to do the same when I use m iPhone.

gibjer
Jul 12, 2008, 01:37 PM
It is definately an Exchange setting.

We have a 2003 exchange server and I have no lock (but I'm the admin ... so that helps)

cualexander
Jul 13, 2008, 12:58 PM
I found the place where you could disable it.(Provided that you are the exchange admin)

http://technet.microsoft.com/en-us/magazine/cc161030(TechNet.10).aspx

Look under Device Password Policies header.

"Many administrators want to know how they can enforce a PIN on the device. In the past, there wasnít a solution built into Exchange (though there are third-party products that provide this capability). But Exchange Server 2003 SP2 now enables you to configure a central policy that requires all mobile device users to protect their device with a password in order to access the Exchange Server.

To specify security settings for mobile devices using Exchange System Manager, right-click Mobile Services and then click Properties. On the Mobile Services Properties dialog box, click the Device Security button. Youíll see the Device Security Settings dialog box shown in Figure 2. To enable password policy for devices, make sure the Enforce password on device option is checked."

Pyronious
Jul 15, 2008, 06:01 PM
The "Enforce password on device" option is set True "out of the box", so it's probably not really a corporate policy issue so much as just the default behavior.

A slightly better way to "fix" the problem is to add your domain account to the list of Exceptions. To do this, click the "Exceptions" button on the "Device Security Settings" panel. Then add your account to the list. Now you won't be required to have a passcode on your iPhone, even if the "Enforce password on device" option is set to True.

bdorpetzl
Jul 15, 2008, 06:42 PM
This is in fact a setting on the Exchange server. It is part of the active sync mailbox policy. Your IT department has set this as a requirement. I had this set I my phone, however, since I administer my exchange box I removed it from my mailbox policies.

whiteshadoww
Jul 22, 2008, 04:53 AM
Not only does it seem to be an exchange issue, it seems that at the exchange level you can allow some iPhones (users) to operate without the passcode requirement and other are subject to the passcode requirement.

My colleague's iPhone out of the box did not require the passcode whereas mine did. I'm in touch with IT to let this brother in without a passcode.

ne0star
Jul 22, 2008, 05:09 AM
This isn't an iphone issue its an exchange security policy setting. It needs to be set on the exchange server.

Just get your network administrator to add you to the exclusions list of the policy. Thats all I did.

There is no way to turn this off from the iphone though.

smoked2na
Jul 23, 2008, 08:19 PM
How to disable Exchange PIN requirement.

a. Jailbreak.
b. SSH into the phone as [ root ]
c. Edit the following file [ "/var/Managed Preferences/mobile/com.apple.springboard.plist" ]
d. Make the following change, setting of the key "minLength" to zero.

<key>PolicyInformation</key>
<dict>
<key>maxFailedAttempts</key>
<integer>10</integer>
<key>maxInactivity</key>
<integer>60</integer>
<key>minLength</key>
<integer>0</integer>
</dict>

e. Now go into preferences and turn autolock off.

At first I upped the "maxInactivity" to "6000" and "minLength" to "0". Then I just set the "maxInactivity" back to "60". Either way, I don't have to use the PIN anymore because the the lock is now off. Whooohooo! :)

Just be aware that the actual mail is not encrypted so anyone that steals your phone can read the Exchange email. Wonder why they didn't encrypt it like the Blackberry does. Maybe iPhone v6.0 in 2010.

littlewaywelt
Jul 24, 2008, 01:50 PM
This isn't an iphone issue its an exchange security policy setting. It needs to be set on the exchange server.

Just get your network administrator to add you to the exclusions list of the policy. Thats all I did.

There is no way to turn this off from the iphone though.

There must be a way to turn it off from the iphone via a hack or program. WM users developed a way around this same feature using mortscript, I think.

Flyby1023
Jul 27, 2008, 06:28 AM
I just ran through an Exchange setup on the iPhone and ran into the passcode problem. My account is hosted with 1&1 and after some give-and-take with them, they assured me the passcode was not a requirement on the server side.

Apple's MobileMe service doesn't require a passcode. I understand why any given company would want to protect their Exchange server with a passcode, so why wouldn't Apple want to protect the MobileMe system with a passcode?

Point being, if Apple doesn't require a passcode and 1&1 doesn't require a passcode, where's it coming from? Exchange is an easier solution for us than MobileMe, but not at the expense of having to enter a passcode every time you pick up the phone.

I would be very interested if someone uncovers the silver bullet to shut this off.

Pyronious
Jul 28, 2008, 01:38 AM
I just ran through an Exchange setup on the iPhone and ran into the passcode problem. My account is hosted with 1&1 and after some give-and-take with them, they assured me the passcode was not a requirement on the server side.

I would be very interested if someone uncovers the silver bullet to shut this off.

Despite the assurances you received from 1&1, I think the problem is still with them. The reason is that when you install Exchange server, the mobile device password requirement is on by default. So if nobody ever makes a decision about it, it's just on.

I found this out when I installed my own Exchange 2003 Server and tried to connect both a Windows Smartphone and an iPhone 3G to it. I had to add myself to the exceptions list to fix it.

Alternately, you can follow the instructions another user left above for the Jailbreak solution, which doesn't require you to convince someone that the Exchange Server is indeed the source of the requirement.

smart2
Aug 4, 2008, 11:12 PM
a. Jailbreak.
b. SSH into the phone as [ root ]
c. delete the following file [ "/var/Managed Preferences/mobile/com.apple.springboard.plist" ] and you are done go ack to password lock and disable it by entering your password

Riemann Zeta
Aug 5, 2008, 10:50 AM
Wow, thanks guys. I knew some l33t iPhone hackers would eventually find a way to do it on a JB phone. Now I just have to wait until the JB process actually works (Pwnage never worked for me w/ OS 2.0.0) and is updated for 2.0.1.

Once again, props for discovering this--it will make email 100% less annoying (and it's not like I work for the bloody CIA).

NightFox
Aug 7, 2008, 06:17 AM
Been there, done that, worn the T-shirt etc etc

I can assure you that this is set by 1and1. I've been using their hosted Exchange account for years and had exactly the same problem with my Windows Mobile phones. And I know that they've told an earlier poster that this isn't the case, but I've had acknowledgement from their admins (rather than just cust servs) that they do, and they won't take it off. Basically, because they're running a hosted business service and could be liable if your Exchange account is hacked, they're trying to protect themselves against their customers having their phones lost or stolen and therefore their Exchange accounts compromised.

You can't actually turn this setting off from a client (e.g. iPhone), but there was a hack for Windows Mobile. From what I remember, you could temporarily change the policy on the phone, but once a day the Exchange server would re-enforce it. The hack was basically just a script that kept checking the registry to see if the policy had been re-enforced on the phone, and if it had it just turned it off again. So basically you couldn't stop Exchange enforcing the policy, but you could just turn it off automatically every time it did.

From what I can see on my iPhone, it doesn't give you the option of manually overriding the policy between enforcements though, at least not through the UI. So I'm not sure how viable it would be a write a similar hack.

vijaywada
Aug 7, 2008, 08:53 PM
Did unlock iphone 3G and disabled policy in "com.apple.springboard.plist" file but no luck.
Exchange client enforces policy almost every time it tries to sync. Policy kicks back in few minutes.

It is interesting to note that only windows mobile and iphones have this policy enforcement, blackberrys don't enforce the policy.

supertyler
Jan 13, 2009, 07:51 AM
I have successfully disabled the email exchange policy based forced password-lock on my iPhone 3G.

This disables the forced and seemingly irreversible auto password lock feature required to synch an iPhone with certain exchange email servers.

I followed the instructions laid out by smart 2 below (thanks!) - but had to a bit of fiddling along the way so here is a bit more detail.

a. Jailbreak.
- I followed the steps described here (http://www.iphonehacks.com/2009/01/jailbreak3g-win.html):

b. SSH into the phone as [ root ]
- Ensure iPhone and Computer are both connected to your WiFi Network
- Install the "OpenSSH" Application via cydia on my Jailbroken Phone
- I have also installed "BossPrefs" Application and use to enable/disable SSH - this may not be necessary.
- Install WinSCP (http://winscp.net/eng/download.php) on your PC.
- Open WinSCP & Enter SSH Parameters along the lines of:

- Host Name: IP Address of iPhone (e.g. 192.168.1.XX)
- User Name: Root
- Password: Alpine
- Port: 22

- Ensure iPhone is not hibernating and click Login.

c. delete the following file [ "/var/Managed Preferences/mobile/com.apple.springboard.plist" ]
- On deleting this file, password settings can immediately be changed/disabled within the "Settings>General" menu - be warned you will need to enter the password before you can disable it.
- Once the password is disabled, no reset appears to be required.
- I have rebooted for good measure, no awkward password is required (as it happens I have now applied the 4 char pin on initial phone access, but certainly no 15 min auto-lock!) and email synch still works.

alchemistmuffin
Jan 13, 2009, 01:26 PM
Note: If your iPhone is company issued, then DON'T JAILBREAK, it might violate the company policy on hacking your electronics. No, this is not at&t killing your phone, it might be your company's iPhone management tool thinking that jailbreak = stolen phone = all your data erased!

If it's not company issued phone, go ahead, it's yours! Jailbreak your phone!

PS: Had similar issue, jailbreak my phone to fix the issue, sent Apple the code on how to fix the issue, and your issue might be addressed on iPhone 2.3 update.

supertyler
Jan 13, 2009, 02:11 PM
Re the solution steps I outlined in previous post - It's been about 6 hours and Exchange has just disconnected further synchronisation and forced me to re-enable the password lock, which I have begrudgingly done.

Hmph - Guess I'll try the other methods identified.

travelerM5
Jan 16, 2009, 10:44 AM
Re the solution steps I outlined in previous post - It's been about 6 hours and Exchange has just disconnected further synchronisation and forced me to re-enable the password lock, which I have begrudgingly done.

Hmph - Guess I'll try the other methods identified.

SuperStyler,

Did you ever manage how to disable the passcode or tweak it. I have heard of killexchage but I thing editing config files is a much cleaner solution.

malwan
May 13, 2009, 02:43 PM
To remove the password lock your exchange admin must update the require password option in the ActiveSyncMailboxPolicy.

Have your Exchange Admin remove the password requirement.
Delete the exchange account from your phone.
Go to the passcode lock section under general settings.
Turn the Passcode Lock Off.
Then re-add the exchange account.



If the password requirement is remove then the passcode lock will remain off.

or your can JB the phone. :)

K.Rock
Sep 4, 2009, 10:28 AM
Would this remove the complete policy that is pushed down from Exchange?

Enabling the Camera, if the policy is set to disable?

sinsin07
Sep 5, 2009, 03:35 PM
Would this remove the complete policy that is pushed down from Exchange?

Enabling the Camera, if the policy is set to disable?

Did you ever consider that tampering with a company initiated security policy could be grounds for termination?

loweyson
Feb 3, 2010, 12:57 PM
did anyone manage to convince 1and1 to add them to the list of exceptions? I've just sent a request to their support.

loweyson
Feb 4, 2010, 09:14 AM
Good news! After a couple of emails with 1and1 support team (support@1and1.co.uk) I managed to get them to run a 'script' (presumably one they've written) to remove the passcode lock on my account.

FYI They call this: 'disable the pin' So use that when asking them for yourselves. Essentially they just add you to a policy exclusion list which disables all requirements. You can then choose to set a passcode, set a pin, or leave it blank.

In the first response they did ask me to confirm my account password and last 4 digits of my credit card. I wasn't that happy about doing this, so I changed my password first. This also highlights they must store passwords as plain text, so be aware!

After confirming they had removed it, and after a few minutes, my iPhone happily allowed me to remove the passcode lock. I've now set it up with the much simpler pin number.

In previous posts I'd noticed a few recommendations to remove and re-add the account, so I'm quite pleased I didn't have to do this. Might be down to the version of the software I'm using: 3.1.2.

Good luck,

Cheers.

djpaul1
May 16, 2010, 12:01 AM
http://portal.johannpaul.com/index.php?option=com_content&view=article&id=26:extensions&catid=25:the-project&Itemid=37

Just follow these steps or refer the attached screenshot



1. Go to Exchange management console (Exchange 2007)

2. Expand Organization - - > Client Access - - > then right click on your client access policy

3. Click the password tab and uncheck require password

4. Thatís it

xcrunner
May 18, 2010, 10:50 AM
http://portal.johannpaul.com/index.php?option=com_content&view=article&id=26:extensions&catid=25:the-project&Itemid=37

Just follow these steps or refer the attached screenshot



1. Go to Exchange management console (Exchange 2007)

2. Expand Organization - - > Client Access - - > then right click on your client access policy

3. Click the password tab and uncheck require password

4. Thatís it

I'm tempted to turn it off myself but I won't ;)

AndyC
Jun 30, 2010, 04:54 AM
How to disable Exchange PIN requirement.

a. Jailbreak.
b. SSH into the phone as [ root ]
c. Edit the following file [ "/var/Managed Preferences/mobile/com.apple.springboard.plist" ]
d. Make the following change, setting of the key "minLength" to zero.

<key>PolicyInformation</key>
<dict>
<key>maxFailedAttempts</key>
<integer>10</integer>
<key>maxInactivity</key>
<integer>60</integer>
<key>minLength</key>
<integer>0</integer>
</dict>

e. Now go into preferences and turn autolock off.

At first I upped the "maxInactivity" to "6000" and "minLength" to "0". Then I just set the "maxInactivity" back to "60". Either way, I don't have to use the PIN anymore because the the lock is now off. Whooohooo! :)

Just be aware that the actual mail is not encrypted so anyone that steals your phone can read the Exchange email. Wonder why they didn't encrypt it like the Blackberry does. Maybe iPhone v6.0 in 2010.

Does anyone know if this can still be done in IOS4?

thanks

intrepid00
Jun 30, 2010, 10:22 AM
Does anyone know if this can still be done in IOS4?

thanks

I hope not, the iPhone is suppose to reset these settings so many hours as defined by the admin.

misku
Jul 8, 2010, 07:32 AM
Install "Exchange unlock" in Cydia (BigBoss repo)

thargenediad
Aug 11, 2010, 02:37 PM
The Autolock of SBSettings package from Cydia might help people who can't disable auto-lock at all, pass code or no pass code.

benmalone1908
Feb 18, 2011, 08:50 PM
I previously installed the "Exchange unlock" in Cydia. I tried deactivating the package in Cydia but it did not reinstate the Exchange password, even after a restart. Any ideas on how to turn it back on?

Rangers Ridge
Aug 5, 2011, 08:46 AM
I just had the heavy hand of IT admin send a passcode neccessary to my personal iphone that I also use for business email- exchange server. I'm not quite ready to try any jailbreaking, but barring that does anyone know of an app that you can set to emulate activity every 14 minutes, 58 seconds, thereby disabling the max 15 min timer on the passcode lock? I would pay top dollar for such an app, and I'm sure there are thousands like me. All you app programmers, take note! Thanks very much in advance for any help on this.

MalusCiaranicus
Nov 5, 2011, 05:40 PM
I just had the heavy hand of IT admin send a passcode neccessary to my personal iphone that I also use for business email- exchange server. I'm not quite ready to try any jailbreaking, but barring that does anyone know of an app that you can set to emulate activity every 14 minutes, 58 seconds, thereby disabling the max 15 min timer on the passcode lock? I would pay top dollar for such an app, and I'm sure there are thousands like me. All you app programmers, take note! Thanks very much in advance for any help on this.

@Rangers Ridge I have just had exactly the same experience with my IT Goons (Global Mobility "Solutions" me arse!). They have pushed the autolock requirement to my personal iPhone when I attempted to add my work Exchange account so I could view my work calendar appointments on the phone (I don't even want the mail!). So anyone who can do this, I'll be on board!

Prototypical
Nov 7, 2011, 09:58 AM
You guys are ballsy, I'd rather not get fired because I'm too lazy to punch in a 5 digit code every so often. Besides, Siri will actually circumvent the code requirement for a lot of functions (outside of exchange-related tasks). Just pull her up and ask her to do whatever you want her to do instead of swiping to unlock.

jtb20689
Feb 4, 2012, 11:40 AM
I was also locked out but I called my IPHONE 4, from another phone. Updated from last comment.
First I double clicked on the home button and started playing a song.
Next I called the iphone from another phone and answered it, hit the contacts icon to look up a name and then double clicked on the home button.
The result was I no longer had that heartless exchange password window pop up :) and could use every function on the phone. Once the phone goes into sleep mode the password window comes up. Possibly, before it goes into sleep you can deactivate the exchange auto logon process. I just got the phone last week so I have no idea how to do that.