PDA

View Full Version : Push -email (Hear a noise) but no email shows up




Aze
Jul 12, 2008, 03:43 PM
Ok, its possible I'm going insane. I've configured MobileMe on my MBP and iPhone 3G. I've been testing sending emails to both my @me and @mac email addresses, in most cases (1/10) the push seems to fail. However, as soon as its sent (I've tried sending it from alternate email address both within Mail and web-based), I hear a vibrating sound (I can't tell from where) that sounds exactly like when you get an email or txt when your iPhone is on silent (even though mine is not). In any event, the email icon does not indicate a new email and a new email is not on the phone until opening the application and then it downloads it via fetch like it always used to. Any suggestions?

Ultimately I want to forward gmail email to my MobileMe account, but those do not seem to push through either.

All mobileme settings are set to sync, it is set to push on both email and calender. The calender is updating as it should. Any ideas?



Jamoke
Jul 12, 2008, 03:50 PM
I found that some of my sounds did not transfer to the 3G iPhone. So when certain contacts call my phone just vibrates instead of using their ringtone. Similar problem with Push E-Mail.... It could be simply that the sound associated is missing, or glitched. Try Re-Setting, and see if that fixes. If not, I'd wait till you have more than 10% of push functioning, and consider it a problem once push is fully functional.

Aze
Jul 12, 2008, 03:59 PM
Ok, i figured it out (well, figured out I'm an idiot).

The sound was my old iPhone - it was sitting across the room on wi-fi and receiving the push messages perfectly, for some reason, the iPhone 3G isn't. Strange.

poma3
Jul 12, 2008, 09:18 PM
This was happening to me too and it was driving me crazy. Eventually I figured out that i have my MobileMe preferences setup to sync my mail rules to my iphone also. The messages were automatically getting moved to my Junk folder or Trash (as the rule instructs). Items in the Junk or Trash register audibly when they arrive on the iPhone but they don't show in the e-mail "count" that is displayed on the mail icon and they aren't, obviously, in your inbox. Hopefully that helps!:D