PDA

View Full Version : Mail.app unread badge wrong




macrlz9
Jul 12, 2008, 05:06 PM
I searched the forums, but didn't find this issue. Since installing the MobileMe update, my Mail on my computer consistently shows I have 10 more messages than I really do. I do have one other mail account set up, but there are no unread messages there. On my iPhone, everything is working. I have tried deleting/re-adding the account,but every time I re-add, the extra 10 come back... Any ideas??



greenmymac
Jul 12, 2008, 05:08 PM
I searched the forums, but didn't find this issue. Since installing the MobileMe update, my Mail on my computer consistently shows I have 10 more messages than I really do. I do have one other mail account set up, but there are no unread messages there. On my iPhone, everything is working. I have tried deleting/re-adding the account,but every time I re-add, the extra 10 come back... Any ideas??

I just checked mine it I sent myself 1 test email and it popped up 1 email

macrlz9
Jul 12, 2008, 05:15 PM
Here is a screenshot... notice the doc icon, and the 5 unread messages in the title.

macrlz9
Jul 13, 2008, 03:59 PM
I tried setting up mail on a guest account, and the unread count in the dock is correct. WTF? Anyone else having this problem?

trainguy77
Jul 14, 2008, 03:03 PM
I have had this problem for months. If you find a fix tell me. One thing that helped me awhile back was create a smart folder for unread items. It showed which ones were unread and i deleted them. That fixed it. Also rebuilding the mailboxes fixed it once for me. But now its back and i can't fix it. :confused:

macrlz9
Jul 14, 2008, 09:34 PM
I have had this problem for months. If you find a fix tell me. One thing that helped me awhile back was create a smart folder for unread items. It showed which ones were unread and i deleted them. That fixed it. Also rebuilding the mailboxes fixed it once for me. But now its back and i can't fix it. :confused:

The smart folder for unread messages worked! I had 10 duplicates that weren't found in normal views. Thanks!

trainguy77
Jul 15, 2008, 12:30 AM
No problem, now if only i could fix mine....:rolleyes:

CaTOAGU
Jul 15, 2008, 04:30 AM
Hmm,

Just a though have you checked that 'Dock unread count' in mails general preferences is set to Inbox only?

trainguy77
Jul 15, 2008, 12:12 PM
Hmm,

Just a though have you checked that 'Dock unread count' in mails general preferences is set to Inbox only?

No i had it set to all. As i have rules that send things to other folders. However, i just set it to using a smart mailbox which was set to be unread only and that fixed it. :D

ocleze
Aug 11, 2008, 10:30 AM
I just reinstalled and restored from a TimeMachine backup. I ended up wth 113 unread messages which didn't appear in the Unread smart mailbox.

It turned out that they were in my Trash folder.
When I expanded the folder there they were..

Empty the trash.. and Poof! Gone..

samh004
Aug 27, 2008, 12:54 AM
Thanks for the fix to create a smart mailbox folder, I've had 1 unread message hiding out for ages, and now it's finally been read. Much appreciated.

stephenfromca
Mar 23, 2009, 12:57 PM
Registered just to post my experience..

Go into each folder in your mail account. I have three mail accounts managed by Leopard Mail. My three "unread" messages were hiding out in one account's junk folder. They were hiding out and didn't show up in the unexpanded "Junk" folder catch-all.

So if you're experiencing this and none of the above solutions work, expand and click into EVERY folder listed in Mail (including Sent, Trash and Junk!)