PDA

View Full Version : my mac pro wont boot if 750gb is in it




SHankara
Jul 16, 2008, 06:50 AM
ii tried installign freebsd on it but when i retsarted it the amc would just go to the white/grey screen,but if i take out the 750 gh hd it boots normally form the main boot disk,is my 750gb toasted?



Spanky Deluxe
Jul 16, 2008, 07:08 AM
Put the 750 gb back in and then turn the machine on while holding the option key down (alt), this will hopefully give you a boot select menu. If it brings up a menu but then seems to get stuck without doing anything for ages then put in and hold the C button down after pressing the power button to boot from disk. Once you're up into OS X or the OS X installer, you'll want to get to your system preferences and set your startup disk as your Macintosh HD one (the FreeBSD install could well be set to the startup volume). You may want to use Disk Utility to sort out your 750gb drive to make it more useful anyway. If this doesn't work then I'm afraid I don't know what to suggest! :(

SHankara
Jul 16, 2008, 07:10 AM
Ive tried holding the option key and the c key to boo form leoaprd disk still stays at white/grey screen

Spanky Deluxe
Jul 16, 2008, 08:02 AM
Hmmm... how old is this 750gb drive? I'd be surprised if it has failed already. Do you have a PC you could put it in? A low level format in the BIOS of a PC could get it working for you. Other than that, you could get an external SATA enclosure or adapter and plug it in when OS X is already live.

Just had another idea, bit off the wall though. Do you have another mac? You could plug in the 750gb into your Mac Pro and boot it holding down the T button to start it in Target Disk mode - then connect it via Firewire to another Mac and use Disk Utility on the other Mac to format the drive.

BTW I think you have to use a wired keyboard for those startup keys.

SHankara
Jul 16, 2008, 08:43 AM
I have 2 other macs,so take out the remaining 3 drives?leave teh 750gb in and start it in target disk mode from the macbook pro?
the 750gb hardrive is about a year old now

Spanky Deluxe
Jul 16, 2008, 09:13 AM
No, you can leave the other drives in. They'll all pop up under target disk mode.

SHankara
Jul 16, 2008, 05:43 PM
target disk mode did not work didnt boot

ThirteenXIII
Jul 16, 2008, 06:17 PM
have you tried your Apple Hardware Test discs?

also does it ever boot at all and what Operating systems are installed on the drives?

SHankara
Jul 16, 2008, 06:29 PM
1 disk is osx other 2 are empty 750 wont boot

ThirteenXIII
Jul 16, 2008, 06:34 PM
I mean is OSX installed on the 750 or is FreeBSD?

if any of the other disks will boot with an OS, it can be pretty assumptive that the culprit is the 750 unfortunately.

however if none of the OS drives are booting, something could be wrong, perhaps bad memory? install any new memory or PCIe cards?


hmmm

SHankara
Jul 16, 2008, 06:49 PM
the only disc that doesnt boot is the 750 gb no os is on it I was aobut to put freebsd on it when it said it couldnt create the filesystem i exit the installer restarted ma wont boot pass grey/white scrreen with 750 gb inside

ThirteenXIII
Jul 16, 2008, 06:58 PM
ok, hm. i assume tried maybe resetting NVRAM? PRAM?
boot into safe mode or from the OSX Disk Utility and reformat the drive?


like the other person said if you had a PC or ability to low-level boot it, it just might need that kick start.


otherwise if its still under warranty RMA it for a new one.


just seems bizarre it is doing that. especially if it was working before?

SHankara
Jul 16, 2008, 07:01 PM
i resetted pram nothing worked,i neevr heard of resetting nvram how do you do that?

i cannot boot into safe mode with the drive inside or boot from and dvd disc if that 750gb drive is inside

Spanky Deluxe
Jul 16, 2008, 07:05 PM
If it didn't even activate target disk mode with the drive in then I'm afraid it definitely sounds like its failed. It should still be covered under warranty, I think most hard drives now have a 3 year warranty as standard and, in my experience, hard drive manufacturers are really good at return/replacements - you'll just have to pay for the shipping to them.

SHankara
Jul 16, 2008, 07:08 PM
when i tried target disk mode the firewire sign didnt even coem up just stuck at the grey whtie screen

Spanky Deluxe
Jul 16, 2008, 07:10 PM
Definitely sounds like its faulty then. Sorry. :(

ThirteenXIII
Jul 16, 2008, 07:10 PM
from my understanding it should have been reset when you did the PRAM reset, excuse my misunderstanding.

then the next step would try a different 750 to see if it replicates.
or try it in an external enclosure.

basically boot up into OSX, place the 750 in an enclosure and plug it in and see if it mounts. if not then most likely osmething failed with the drive.

probably best to get a replacement =\


goodluck!

SHankara
Jul 23, 2008, 08:21 PM
well i fixed it!

went to a firends place to let them boot the hd it booted turns out freebsds boot manager conflicts with the boot manager of osx? or efi firmware so i popped in a linux live cd and reformated the hd