PDA

View Full Version : 2.0 Firmware.... disappointing quality/performance




Snips
Jul 16, 2008, 08:32 AM
Hey,

I'm an Apple fanboi as much as the next person on here, but I can't help but find the 2.0 firmware disappointing from a performance/quality perspective.

Here's what I've noticed so far, based on using 2.0 on my 1st gen iPhone:

- Google Maps was super-reliable at finding my location with 1.1.4, now it often just spins the progress wheel, but fails to actually locate me by either wireless or cell tower. Now I think, "will it work" (and half the time it doesn't), whereas before, "it just worked". When it does work, it's great at tracking me, but I'd rather it was more reliable everywhere.

- When opening up an app (such as Contacts), there is sometimes a lag before the UI is responsive. I appreciate apps have a splash screen that may look like the app, but this seems more than that.

- Some of the transitions are not as smooth as they used to be.

- A forum I like to post on from my iPhone now doesn't work. I get the text box for typing in to, but when I begin to type, it's as if I've hit return. I very much doubt the website itself has changed.

- Mobile Safari is less errrr, snappy ;) Edge downloads are slower. I'm concerned that Steve's 3G download comparisons we're against the new (and, I suspect, slower) 2.0 download rates.

Overall, the 2.0 feels like it was rushed out. I just hope they spend some time getting the quality back to where it was, 'cos right now the software quality problems are a distraction from what is an awesome device.



Nym
Jul 16, 2008, 08:59 AM
- Google Maps was super-reliable at finding my location with 1.1.4, now it often just spins the progress wheel, but fails to actually locate me by either wireless or cell tower. Now I think, "will it work" (and half the time it doesn't), whereas before, "it just worked". When it does work, it's great at tracking me, but I'd rather it was more reliable everywhere.

- When opening up an app (such as Contacts), there is sometimes a lag before the UI is responsive. I appreciate apps have a splash screen that may look like the app, but this seems more than that.

- Some of the transitions are not as smooth as they used to be.

- A forum I like to post on from my iPhone now doesn't work. I get the text box for typing in to, but when I begin to type, it's as if I've hit return. I very much doubt the website itself has changed.

- Mobile Safari is less errrr, snappy ;) Edge downloads are slower. I'm concerned that Steve's 3G download comparisons we're against the new (and, I suspect, slower) 2.0 download rates.

1 - I was also kinda disappointed by Google Maps "Locate Me" feature because it just kept spinning until I got tired of waiting for it.
Then I walked outside... in 3 seconds I had a pinpoint location of where I was. I was actually surprised :D

2 - The contact list lag is happening to a lot of people with multiple configurations on their iPhones. This is most certainly being addressed by Apple Developers in their next bug fix. But I agree with you, it lags :)

3 - The transitions look fine to me. I was using an iPod Touch with 1.1.4 before I bought my iPhone and everything seems "normal".

4 - Yes, this happens sometimes. I also try logging in at my mobile carrier's website to send free sms through a web form and every time I try to type my password is like nothing is being typed at all.

5 - I seriously don't know. I really haven't noticed any changes in the download speed.

However, YouTube takes forever (through WiFi) to load a 3 minute clip! :D