PDA

View Full Version : Problems with Apple TV streaming (using ethernet)




eyemac1000
Jul 18, 2008, 09:39 PM
This is my first post on these forums, so my apologies if this has been covered elsewhere. The apple TV is connected to my network via ethernet through a linksys router. When I use the sync option the device works flawlessly, but when I switch to streaming it can pause and even freeze on some files. Is it a router setting that's causing the problem?



rundallm
Jul 19, 2008, 08:51 PM
Hello:

You can't stream via ethernet. Only via wireless router. You can sync via ethernet though.

Hope that helps!

nittany
Jul 19, 2008, 09:27 PM
Hello:

You can't stream via ethernet. Only via wireless router. You can sync via ethernet though.

Hope that helps!

Hunh? That's not correct. You can do either with either.

nittany
Jul 19, 2008, 10:13 PM
Interesting, I was willing to write off a similar experience as a fluke or my imagination, but see your post makes me wonder...

So we're on the same page, I turned off wireless in my house last year and installed 10 gigabit capable structured cabling. Excluding the :apple:TV (which for some unknown reason only sports a 10/100 ethernet port), everything else attached to my LAN is 1 gigabit capable. Gone are the days of wobbly connections and random speed changes.

I've always kept all of my content (music, TV, movies) on various drives connected to a Mac mini used as the iTunes server paired with the :apple:TV. The only content kept on the :apple:TV was photos, as I was under the impression they could not be streamed. To accomplish this stream/sync combination, I established a sync connection, but then on each iTunes tab for the :apple:TV, I de-selected the sync option - except of course for photos. Overall, the configuration did what it was supposed to do. With nothing negative to report except that I had to sync the photos, I was pleased with the result. No freezes, no jumps, no nothing other than a smooth presentation of the content.

Anyway, I saw a video online earlier this week that showed it was possible (it may have been before as well) with ver. 2.1 to stream photos, so I killed my :apple:TV's connection to iTunes on the mini and re-established the connection to the mini as a shared computer. It worked and I now now have 100% of my content set to stream. The problem is that for the content that streamed in my old configuration (music, movies, TV), it no longer responds in the same way.

When I access (say) music, I get a spinning wheel and some message saying it's connecting, then I get the content. The same thing occurs with movies and TV. For movies and TV content, when initially shuffling through entries the :apple:TV displays a strip of analog film where the artwork should be located, which eventually appears. When fast forwarding through music or movies, it initially responds, but then sort of gives up and stops. Lastly, while I might not have it set up correctly, I can't get my photos to be used by the :apple:TV screen saver. I can supposedly do so with photos on Flickr or MobileMe, but I don't use either.

I'll give the pure streaming more review time, but if it continues to act this way, then I'll convert back to the old way of streaming. It's just kind of weird that while both methods stream the content, one (so far) works much better than the other.

severe
Jul 20, 2008, 12:24 PM
This is my first post on these forums, so my apologies if this has been covered elsewhere. The apple TV is connected to my network via ethernet through a linksys router. When I use the sync option the device works flawlessly, but when I switch to streaming it can pause and even freeze on some files. Is it a router setting that's causing the problem?

I've been streaming via ethernet for most of the time I've owned my AppleTV. I've had few issues. I would guess that it's a router issue, as you suggested. If you don't have another router to test, try to borrow one from a friend.

Good luck and welcome to the forums.

eyemac1000
Aug 5, 2008, 08:41 PM
I finally got a chance to try what the second previous poster suggested: that is custom syncing appleTV to itunes but unchecking movies, podcasts and music. Streaming seemed to work quite a bit better... although I kept getting some problems with fast forwarding... I believe that was because I didn't give the appleTV enough time to adequately buffer the stream. That brings me to my next question: does anyone know what size buffer the appleTV uses when streaming?

Toups
Aug 13, 2008, 04:36 PM
I have been using wired ethernet to stream and has been working flawlessly.

Couple of things to note
1. Be sure your host is connected to the same router/switch (not a hub) and configured for the same subnet (255.255.255.0 or smaller recommended)
2. Set the wireline speed on the router switch manually instead of auto (configure port to AppleTV @ 100Mbps/Full)
3. Be sure the host PC and router/switch port is manually set to 100Mbps or faster/Full-Duplex
4. Ensure router/host does not have a SPI firewall configured for the ports/segments both machines are connected to
5. Use only Cat5e or better cables, jacks and connectors (certified to 250Mhz or higher) as a chain is only as strong as its weakest link.