PDA

View Full Version : How do i make me emails stay on the server after i delete it.




btnnaz
Jul 27, 2008, 07:04 PM
Anyone know how. if i delete them from my phone it deletes it from my computer and i don't want it to do that.

Any Help is Greatly Appreciated



skubish
Jul 27, 2008, 07:26 PM
Goto Settings>Mail>Cox>Advanced: Set delete from server to Never.

PS: you only get push with Yahoo and mobileme mail.

btnnaz
Jul 27, 2008, 07:28 PM
Goto Settings>Mail>Cox>Advanced: Set delete from server to Never.

PS: you only get push with Yahoo and mobileme mail.

Yes i know that but i got it working by making it forward to my me account but then it deletes it from my me server. how do i make it just delete the me emails on my phone

So basically what i am asking is how do u make it so that when u delete a me email from your phone it doesnt delete from the server

skubish
Jul 27, 2008, 07:33 PM
Yes i know that but i got it working by making it forward to my me account but then it deletes it from my me server. how do i make it just delete the me emails on my phone

So basically what i am asking is how do u make it so that when u delete a me email from your phone it doesnt delete from the server

What causes your mail to be deleted from the server? Does it delete when you deleted it on the iPhone? If so, then the solution is what I gave you above.

Could it be that the mail is being deleted when it is forwarded? Maybe some setting with Cox you need to address.

btnnaz
Jul 27, 2008, 07:35 PM
um Did you read my post?:confused:

Yes...... i know it never deletes it from my cox server but it still deletes it from my me server

btnnaz
Jul 27, 2008, 07:40 PM
What causes your mail to be deleted from the server? Does it delete when you deleted it on the iPhone? If so, then the solution is what I gave you above.

Could it be that the mail is being deleted when it is forwarded? Maybe some setting with Cox you need to address.

The email is forwarded to my me account so it is pushed to my phone. Then when i delete an email on my phone it deletes it from my computer at home which is also set to my me account. So it is deleting it from the me server. I know it's not a cox problem i just want to know how to make it stay on the ME server after i delete it not the cox server

abijnk
Jul 27, 2008, 07:43 PM
Turn off push. The point of push is that everything it synced, this includes deleting and moving emails. So, if you don't want it to do that, then don't push your mail.

Chundles
Jul 27, 2008, 07:44 PM
MobileMe is IMAP based - whatever you do to any client for that account, be it your iPhone or your computer or web-based, is reflected on all other accounts.

Mark something as read - it's marked as read everywhere. Delete a message from anywhere and it's deleted. It's much more convenient than POP which does everything locally.

skubish
Jul 27, 2008, 07:50 PM
The email is forwarded to my me account so it is pushed to my phone. Then when i delete an email on my phone it deletes it from my computer at home which is also set to my me account. So it is deleting it from the me server. I know it's not a cox problem i just want to know how to make it stay on the ME server after i delete it not the cox server
Can you change the setting for mobileme mail like other mail accounts on the iPhone?

aristobrat
Jul 27, 2008, 07:55 PM
Turn off push. The point of push is that everything it synced, this includes deleting and moving emails. So, if you don't want it to do that, then don't push your mail.
Even if the OP turns off push, if he deletes anything on his iPhone, it will eventually sync what he did back up to the server. Push generally makes things happens faster, but doesn't really add any extra options for how to delete stuff, etc when it comes to keeping things in sync.

Chundles nailed it. MobileMe is IMAP based, so it's working as designed.

The only thing I can think of trying is to manually resetup MobileMe on the iPhone as a POP account, but then the OP wouldn't get any push. He'd have to wait every 15/30/45/60 minutes for his device to sync before he got new email.