PDA

View Full Version : CSS and horizontal rules


brianellisrules
Jan 1, 2004, 07:17 PM
Howdy folks.

My page isn't displaying properly on Safari browsers. My horizontal rules are all left aligned (when on every other browser, they're center aligned).

Here's the code from my CSS:
hr {text-align: center; margin-top: 0; margin-bottom: 5px; }

(I've also tried align: center; but that doesn't seem to work either).

Here's an example:
http://www.brianellisrules.com/archives.php?id=A2003121

the page views properly on IE and Mozilla on Windows... but this is my first time checking it out on Safari and it's bugging me.

Any ideas? My initial guess is that it's inheriting some rules from my other tags, but wouldn't having the CSS align it to the center override that? My other guess is that my CSS code is wrong. What do youn's think?

Thanks!

fugeelama
Jan 1, 2004, 08:11 PM
you could always try using hr align="center" in the actual tag...

brianellisrules
Jan 1, 2004, 10:29 PM
Originally posted by fugeelama
you could always try using hr align="center" in the actual tag...
True dat, true dat.

But since I have a bunch of hr's floating around my webpage, that's a lot of align="center"s I'd need to add... which sort of defeats the purpose of CSS... right?

mrjamin
Jan 2, 2004, 08:12 AM
have a look at this - its a safari bug.

http://masterkill.com/misc/safari-hr.html

brianellisrules
Jan 2, 2004, 09:47 AM
Originally posted by mrjamin
have a look at this - its a safari bug.

http://masterkill.com/misc/safari-hr.html
Doh! Thanks for the link.

mrjamin
Jan 2, 2004, 10:06 AM
Originally posted by ber.com
Doh! Thanks for the link.
its been fixed in the latest webcore builds which are supposed to make their way into safari 1.2 - have a look on macrumors page 2 and follow the link in there for more info on fixes

mrjamin
Jan 2, 2004, 10:07 AM
Originally posted by ber.com
Doh! Thanks for the link.
its been fixed in the latest webcore builds which are supposed to make their way into safari 1.2 - have a look on macrumors page 2 (http://www.macrumors.com/pages/2003/12/20031231140536.shtml) and follow the link in there for more info on fixes