PDA

View Full Version : What DID they fix?




The General
Aug 5, 2008, 11:07 AM
So just which bugs did they fix in the 2.0.1 update? Well, we know they didn't fix these problems:

1. Laggy contacts.
2. Slow keyboard in SMS sometimes that can be fixed by closing and reopening SMS.
3. Really slow application installation.
4. Awkward and awful application update.

The only good thing that I've noticed about this update is that the reception indicator is a lot more accurate. There's a section of road I drive through every day that has no service. It's literally 100 yards long, and the iPhone used to go from full 3G to No Service and then hang at that for a really long while, even though I could send and receive texts and calls. But now it goes down one by one 5 4 3 2 1 no service 1 2 3 4 5 bars and it seems to actually represent my real reception.

But come on! I don't care about that, I want the other bugs fixed first. :(



AustinSTI
Aug 5, 2008, 11:34 AM
I dunno what your are smoking but the issues you list (SMS, Contacts Lag) are much better for me so far, while the signal meter is exactly the same as pre-update so I'd say they fixed those thing you say they didn't and the things you think they fixed are in your head/they didn't fix.

Maybe you are in bizarro land (AKA Canada)

M0bile
Aug 5, 2008, 12:24 PM
So just which bugs did they fix in the 2.0.1 update? Well, we know they didn't fix these problems:

1. Laggy contacts.
2. Slow keyboard in SMS sometimes that can be fixed by closing and reopening SMS.
3. Really slow application installation.
4. Awkward and awful application update.


For me:

1. Fixed (SUPER HAPPY ABOUT THAT)
2. Fixed (except in Mail.app, I send emails as texts)
3. Never was a problem for me.
4. See 3... ?
:D

atiffarooq
Aug 5, 2008, 12:28 PM
I've just used my iPhone since updating and the contacts speed and SMS lag definitely seems to be reduced. I'll need to test over a day or so though to be absolutely sure ...

TEG
Aug 5, 2008, 12:29 PM
So just which bugs did they fix in the 2.0.1 update? Well, we know they didn't fix these problems:
1. Laggy contacts.
2. Slow keyboard in SMS sometimes that can be fixed by closing and reopening SMS.
3. Really slow application installation.
4. Awkward and awful application update.


1) Fixed for most who were having the problem with the Contacts App. Few reports of any problems for contacts in the Phone App in the first place.
2) Fixed.
3) Fixed. Was mostly a server issue, with signing the application onto the device.
4) Mostly a server issue. Mostly fixed as of this morning.

I have noticed, that with the exception of the ringtones, the phone makes no noise when headphones are plugged in.

TEG

The General
Aug 5, 2008, 12:34 PM
1. Nope, scrolling is still choppy as hell. Tapping on a contact may or may not work. And it's not like I have a thousand contacts.
2. When I get a text message and I tap the "reply" button, THIS is when I get the slow keyboard issue.
3. I have like 25 applications installed and application installation in EXACTLY the same for me. It takes FOR. EVER.
4. Since application installation takes FOREVER, updating applications takes FOREVER also.

PayPal Mobile is going on 4 minutes now. That's how long it's taking to install for me.

WTF.

EDIT: Ope! Thought it was done but it really just started the installation over. Going on 5 minutes now.
EDIT EDIT: Finally finished. 6 minutes. Unacceptable. Program sucks. Deleting.

AFPoster
Aug 5, 2008, 12:40 PM
General I havent gotten the update yet since I am at work and didnt realize it launched before I left my house. However I am having the same issues as you so when I do the update I will let you know if it fixes my issues. Also try a hard reboot on your iPhone like shut it down, keep it off for a few minutes and turn it back on. Maybe even run the battery down till the iPhone shuts off on you and charge it completely, then do the reboot.

Small White Car
Aug 5, 2008, 12:41 PM
1. Laggy contacts.


Fixed it for me. It used to take 12-20 seconds to load the address book and now it consitantly takes 4-5 seconds. I call that "fixed."


4. Awkward and awful application update.


That's not a bug, that's just bad program design. I sure hope they fix this too (in 2.1.?) but since it's not a bug I never expect it to be fixed here.

michael31986
Aug 5, 2008, 12:46 PM
they need to fix the alert sounds for texts.

FJR
Aug 5, 2008, 01:10 PM
So just which bugs did they fix in the 2.0.1 update? Well, we know they didn't fix these problems:

1. Laggy contacts.



Fixed that for me. Went from about 8 seconds to load contacts to maybe 1-2. And once contacts are loaded there are no lags whatsoever for me.




2. Slow keyboard in SMS sometimes that can be fixed by closing and reopening SMS.



Again, fixed that for me, no lags whatsoever replying to texts.




3. Really slow application installation.



I've never really thought it should take less than 2-4 minutes. I guess that's just me.




4. Awkward and awful application update.



I've found that updating from iTunes is awful, but if I just use my iPhone for updates, everything works great. Then it just syncs them back to iTunes the next time I sync up.



I also have found that my reception seems to be SLIGHTLY better and the bars are more accurate.

cellocello
Aug 5, 2008, 01:16 PM
I'll chime in that, generally, everything seems a bit better and "snappier" (thought I had some problems updating, and I'm still sort of 'off' over that) with the update in place.

HOWEVER, I am sad to report that I just replied to a txt msg and my keyboard started lagging again.

slicecom
Aug 5, 2008, 01:19 PM
Maybe you are in bizarro land (AKA Canada)

No, I can confirm that even here in bizarro land, the update fixed those issues. :)

Small White Car
Aug 5, 2008, 02:37 PM
Sorry but I had to LOL at that one. :D

Well, it's true!

A 'bug' is when something doesn't work the way the designer intended it to.

As far as I can tell, the installer is working the way they made it. They just didn't spend much time making it work in a way that makes sense. But it's doing exactly what they told it to do.

georgeoommen
Aug 5, 2008, 02:47 PM
following to 2.0.1 update, I have lost all locate me and GPS functionality.. I hit the locate me button but it just sits there with the thing circling. I have left it on for close to 10 minutes with just touching the screen every minute to make sure it doesn;t go to auto lock and nothing.. it doesn't manage to lcoate me or anything at all for that matter..

anyone else have this problem?

Pandora01
Aug 5, 2008, 02:52 PM
they need to fix the alert sounds for texts.

They didn't fix this??? :mad: Great, that means I'll have to keep resetting my phone every time the sounds cut out again, which is a major PITA. *grumble*

zainjetha
Aug 5, 2008, 02:56 PM
Ok, by the looks of things i'm staying on 1.1.4 until it's perfect. I dont want sms lag times because i use it so often.. wouldnt want to take a risk like that...

zainjetha
Aug 5, 2008, 02:56 PM
Ok, by the looks of things i'm staying on 1.1.4 until it's perfect. I dont want sms lag times because i use it so often.. wouldnt want to take a risk like that...

applehappy
Aug 5, 2008, 03:08 PM
1. Nope, scrolling is still choppy as hell. Tapping on a contact may or may not work. And it's not like I have a thousand contacts.
2. When I get a text message and I tap the "reply" button, THIS is when I get the slow keyboard issue.
3. I have like 25 applications installed and application installation in EXACTLY the same for me. It takes FOR. EVER.
4. Since application installation takes FOREVER, updating applications takes FOREVER also.

PayPal Mobile is going on 4 minutes now. That's how long it's taking to install for me.

WTF.

EDIT: Ope! Thought it was done but it really just started the installation over. Going on 5 minutes now.
EDIT EDIT: Finally finished. 6 minutes. Unacceptable. Program sucks. Deleting.

Dude! What a whiner. Really, six minutes to install an app! How can this be? Just chill. Sounds like your experience is not the common one. Your mileage may vary. Try a restore. Then apply to work at Apple. Just tell them you have all the answers.

markgamber
Aug 5, 2008, 04:29 PM
What I find odd is that for the most part, the SMS keyboard lag and SSSLLLOOOWWW contact list are fixed. However, I've seen both problems after the update. Not often, mind you, but I can't say they are at 100% yet. Maybe next time. On the other hand, I haven't had an app crash on me yet since updating. Not that they crashed all that often before, but Safari wasn't exactly the most stable thing I've ever used.

BergerFan
Aug 5, 2008, 04:36 PM
I'm sooo happy! For me, all the bugs have been fixed.
No lag whatsoever, 3G connection is more stable, and faster. the HSDPA is basically as fast as my Wi-Fi(I just wish the image and video quality was the same as Wi-Fi though).
Locate me is now instant, Safari is indeed 'snappier' :D
I'm back to 1.1.4 Joy!

Sorry to hear about other people's problems, but for me, it's back to form, :)

Virgil-TB2
Aug 5, 2008, 04:46 PM
...Well, we know they didn't fix these problems...Wow, you really don't understand the difference between "I'm having problems with a product" and 'this product (universally) sucks" do you? :) ...1. Nope, scrolling is still choppy as hell ... I have like 25 applications installed ... PayPal Mobile is going on 4 minutes now. That's how long it's taking to install for me. ... WTF. ... Going on 5 minutes now ... Finally finished. 6 minutes. Unacceptable. Program sucks. Deleting.This is just childish crap.

Seems to me like you are pushing your devices to the wall, and then complaining when they break or don't meet your wildly high expectations. You also sound petulant and immature about it.

Maybe take your ADD pills or whatever? It might be your only hope for these kinds of "problems." ;)

adversecamber
Aug 5, 2008, 04:50 PM
I dunno what your are smoking but the issues you list (SMS, Contacts Lag) are much better for me so far, while the signal meter is exactly the same as pre-update so I'd say they fixed those thing you say they didn't and the things you think they fixed are in your head/they didn't fix.

Maybe you are in bizarro land (AKA Canada)

Interesting this entry (no. 2) was edited for quoting too much of the first post, but the racism was left in.

Hudzilla
Aug 5, 2008, 04:50 PM
I'm sooo happy! For me, all the bugs have been fixed.
No lag whatsoever, 3G connection is more stable, and faster. the HSDPA is basically as fast as my Wi-Fi(I just wish the image and video quality was the same as Wi-Fi though).
Locate me is now instant, Safari is indeed 'snappier' :D
I'm back to 1.1.4 Joy!

Sorry to hear about other people's problems, but for me, it's back to form, :)

+1.

Pandora01
Aug 5, 2008, 05:35 PM
Interesting this entry (no. 2) was edited for quoting too much of the first post, but the racism was left in.

Also, since when do the mods trim down quotes? I've seen people quote HUGE blocks of text superfluously without getting edited. Weird.

(BTW, I don't think a joke about Canada is "racism." And yes, I am Canadian. We're supposed to have a charmingly self-deprecating sense of humour up here, remember? ;) )

trunksu
Aug 5, 2008, 05:49 PM
well when i had first updated contacts was smooth. but i just tried it now and it's still slow like before (3-5sec loading). i've always had that 3-5 sec lag but i guess it's fast compared to people saying they have 30sec load times :eek:

allurbase
Aug 5, 2008, 05:56 PM
1. Fixed
2. Fixed
3. Never a problem
4. Never a problem

My phone does sometimes stop making my SMS notification tone, but it's only happened once be4 2.0.1 and once since. I just turn the phone on and off and it comes back.

nyfinest32
Aug 5, 2008, 05:59 PM
my sms is still laggy at times :mad:

my gps seems to be working fine atm

GreenLightJerky
Aug 5, 2008, 06:10 PM
Locate Me is not working.
Battery life is now about 50% of what it was as of yesterday
Still some lag in the contacts.
WIFI not always connecting, when prior to today there was never an issue.
Have not experienced any crashing yet

fishmd
Aug 12, 2008, 10:58 AM
Just to bring this back up again. I find it strange that I initially had all of these problems "fixed" after the update. I thought, what a bunch of crap, all of these people saying it did not fix anything. They are so wrong. A week later and now I am back to where I was before the update. Contacts lag when opening for 5-10 seconds with choppy scroll. SMS is laging more often than not now. This stuff is driving me crazy....

Anyone else out there initially see these things fixed when the updated to 2.0.1 and now not so much?:mad:

ascender
Aug 12, 2008, 11:00 AM
You can add me to the list of people who still have these problems following the installation of the latest update.

TexasBlake
Aug 12, 2008, 12:14 PM
Wow, you really don't understand the difference between "I'm having problems with a product" and 'this product (universally) sucks" do you? :) This is just childish crap.

Seems to me like you are pushing your devices to the wall, and then complaining when they break or don't meet your wildly high expectations. You also sound petulant and immature about it.

Maybe take your ADD pills or whatever? It might be your only hope for these kinds of "problems." ;)


Since when is pushing a button wanting an application to load a "wildly high expectation?" Especially when my phone worked flawlessly for a year.

I have been having all of the same problems. I've never had any problems with my iPhone until I upgraded to 2.0 and 2.0.1. Takes an average of 8 seconds for the Contacts app to be responsive, I have 48 contacts. Whenever I send an email, and for the TO field push teh + button to load contacts, it takes about 15-20 seconds. Honestly, I don't know why there has to be a seperate Contact app in the first place. The same thing loads up after pushing the phone button.

Honestly, that's why I joined this forum; to see who else is having these problems. I want to know if it's a 1st gen vs. 3G problem or software problem.

seedster2
Aug 12, 2008, 01:11 PM
exchanged my phone yesterday with a phone preloaded with the updated firmware.

Phone still exhibits lag when accessing contacts, the SMS keyboard will go berzerk from time to time, and I get unresponsive home screens...

chimpboy74
Aug 12, 2008, 02:01 PM
You can add me to the list of people who still have these problems following the installation of the latest update.

yep me too. And my wife.

GPS MAY be slightly better (in that it can now locate me when I am in my house whereas before it was about a mile out - not sure if that is die to 2.01 or not)