PDA

View Full Version : OS X Server on VMware Fusion




d9pe
Aug 7, 2008, 02:48 PM
i just tested Mac OS X Server on VMware Fusion 2 Beta 2

http://gallery.me.com/d9pe#100032

its just great...

some one got also experience with that?



louden
Sep 18, 2008, 10:42 AM
Did you burn a CD/DVD image?

Is there a way to just point the DMG file to Fusion when you want to create a new VM? It looks like Fusion can only work with actual media or ISO files...

suprajoe
Sep 19, 2008, 12:53 PM
I just got the update Fusion 2.0 and am about to install Mac OS X Server on it shortly. I will post up my experience when I'm done.

aplnub
Nov 18, 2008, 03:59 PM
I just got the update Fusion 2.0 and am about to install Mac OS X Server on it shortly. I will post up my experience when I'm done.

How about an update?

I have installed Server now several times on my iMac in Fusion and it is working fine, minus the fact I am having DNS problems so I can't invite other users on the network. A problem for a later discussion since I am not familiar with Leopard Server and am trying to learn.

ghostalker
Nov 18, 2008, 10:08 PM
I am thinking of also trying OS X server in a VM

To what extent does Fusion support virtual networking? Their product literature us not clear on this.

Is it possible to network between isolated VM instances?
Will it support multiple virtual IP addresses?

RHochstenbach
Feb 11, 2009, 03:38 PM
I'm trying to install Mac OS X 10.5 Server on Fusion as well, but it doesn't seem to work. I see the Apple logo and then the OS X Server wallpaper. But nothing happens. I only keep seeing the famous beech ball as mouse cursor :confused:

RHochstenbach
Feb 12, 2009, 09:28 AM
I just found a way to get OS X Server to install and to boot. When turning on the virtual machine, hold down SHIFT. When the Apple logo appears, keep holding shift. Just after that, you are able to get it working. It's in safe-mode, but it works.

However when I don't use safe-mode when I want to boot OS X Server, it doesn't do anything. When running it in Verbose mode, I only see the message "RpcOut_Send returned a failure". At the end of line first line, ATSServer is mentoined, and at the second is loginwindow mentioned. Those lines keep appearing and I can't boot normally :confused:


UPDATE: I've just updated Mac OS X Server to 10.5.6. Now I see the following message: AF ALERT: socketwall_cntl_updaterules ctl_enqueuedate rts err 55. I notice hige HDD activity, and then it just freezes.

UPDATE2: I solved the problem. First I've loaded the installation program of Mac OS X Server and used the Disk Utility to repair file permissions. Then updated Fusion to version 2.0.2. I then got a message that VMware tools was outdated. Installed VMware Tools, rebooted and then I could boot Mac OS X Server normally :)

kremer4
Mar 10, 2009, 10:12 AM
I've got it running on my iMac.

I'm hosting 3 of my websites on Leopard Server running on my iMac in Vmware fusion 2.0.2

mgodfre3
Mar 13, 2009, 11:51 AM
I am a mac sys admin, and I have installed and had in production a leopard server running virtual through fusion on an xserve. I use the server for Symantec Admin Console, Apple Software Update Server and as a Task server for ARD. So far it has been a champ, and as I would rather use VM ESX like the rest of my setup for windows(about 80 vms total) this seems to do the trick for now.