PDA

View Full Version : Reinstall Samba for 10.5.4 from scratch




fishinatree
Aug 8, 2008, 09:22 PM
Rather a weird situation here...for some reason I don't have Samba on my computer at all. the commands 'findsmb', 'swat' and other Samba-related commands don't work. 'sudo swat' gives me: dyld: Library not loaded: bin/libtalloc.dylib
Referenced from: /opt/local/sbin/swat
Reason: image not found
Trace/BPT trap

and 'findsmb' gives me
dyld: Library not loaded: bin/libtalloc.dylib
Referenced from: /opt/local/bin/nmblookup
Reason: image not found
I couldn't find any Console output for either of these commands.

Can someone please help me reinstall Samba on my intel Macbook? I didn't really know what kind of information to give, but I can give whatever information is necessary to fix this. Thanks!
f][sh



corbywan
Aug 8, 2008, 09:47 PM
Which OS are you on? Have you turned on Windows/SMB sharing to see what it does?

fishinatree
Aug 8, 2008, 10:19 PM
I'm in Mac os X right now. How do I turn on Windows/SMB sharing?

corbywan
Aug 8, 2008, 10:47 PM
Depends on OS. In Tiger, in System Prefs/Sharing i think there is a Windows Sharing checkbox. In Leopard, go to System Prefs/Sharing/File Sharing, check the box, then click on the Options button in the lower right of the window, then select the SMB option.

The built-in Help should be more direct if that was confusing.

fishinatree
Aug 9, 2008, 01:11 PM
I fiddled around with some Samba stuff and recompiled it from source (Samba 3.2.0). When I use various Samba related commands like 'findsmb', I get the following error message:

dyld: Library not loaded: bin/libtalloc.dylib
Referenced from: /opt/local/sbin/swat
Reason: image not found
Trace/BPT trap

When I run findsmb from Samba-3.2.0/source, however, the command 'findsmb' works! What's going on?

corbywan
Aug 9, 2008, 07:29 PM
What is it you are trying to do that the built-in methods for sharing with Windows machines won't do?