PDA

View Full Version : Painfully slow connection to the internet




masterp34588
Aug 16, 2008, 12:40 PM
I have two computers (Macbook, iMac) both running Leopard and my internet speed has been incredibly slow the past several weeks. At times it feels about the same speed as dial-up even though I'm on cable. I just ran a speed test (speedtest.net) and my download speed is 180 kb/s and my upload is 396 kb/s. I have a buffalo router (running dd-wrt) and my own cable modem. I'm not sure where the problem is originating and how to fix it. I am actually writing this post in textedit because I have yet to get the forum page to load. I've hopped into Network Utility to run a traceroute to google.com and it's frequently either timed out or takes several minutes. I started a traceroute to www.google.com and wrote this post..and the traceroute is still running.

Here is the log of a ping I just sent out to Yahoo.

PING www.yahoo-ht3.akadns.net (69.147.76.15): 56 data bytes
64 bytes from 69.147.76.15: icmp_seq=0 ttl=50 time=56.097 ms
64 bytes from 69.147.76.15: icmp_seq=3 ttl=50 time=55.133 ms
64 bytes from 69.147.76.15: icmp_seq=4 ttl=50 time=55.921 ms
64 bytes from 69.147.76.15: icmp_seq=5 ttl=50 time=57.690 ms
64 bytes from 69.147.76.15: icmp_seq=6 ttl=50 time=57.718 ms
64 bytes from 69.147.76.15: icmp_seq=7 ttl=50 time=55.226 ms
64 bytes from 69.147.76.15: icmp_seq=8 ttl=50 time=61.052 ms
64 bytes from 69.147.76.15: icmp_seq=9 ttl=50 time=56.301 ms

--- www.yahoo-ht3.akadns.net ping statistics ---
10 packets transmitted, 8 packets received, 20% packet loss
round-trip min/avg/max/stddev = 55.133/56.892/61.052/1.817 ms


I'm getting 20% packet loss. I'm not certain how to pinpoint where this problem is originating. So, should I be calling up my ISP and complaining about this, or could this possibly be a setting in dd-wrt that got messed up? Any help is appreciated. Thanks in advance.



jjtuttle
Dec 4, 2008, 08:35 AM
I have the exact same problem. I have a Buffalo WHR-G54S running DD-WRT v24-sp1 (07/27/08) vpn - build 10011. My wife first noticed the problem in August, too. It was fine prior to that. Connection to the router, even when just inches away, is 70% with 15% noise. From another room it drops to 50% of 20% with 50% noise. I've tested the same router and locations with a Thinkpad T-60 (Ubuntu 8.10/Windows XP) and a Thinkpad X200 (Ubuntu 8.10/Windows Vista) and all 4 of those configurations work excellent with the router. The Macbook wireless works quite well with other wireless networks that I've tried.

I first thought perhaps it was WPA2 TKIP/AES encryption slowing the connection down. Using WEP128 then no encryption didn't help. Changing channels, rebooting both laptop and router didn't help. iStumbler confirmed the connection was very poor. I flashed the router to Tomato 1.22 with no change. I flashed back to dd-wrt with no change.

I assume that taking the Macbook and router into an Apple store will be a waste of time and money, but have very few alternative ideas. I think tonight I'll boot the Macbook from a Knoppix Linux live CD to confirm that the problem is an OSX problem rather than an Apple hardware problem. I guess the next step is to buy a new router, although I love my Buffalo.

Does anyone have any ideas?

rat tat tat
Dec 5, 2008, 12:54 AM
Try this to see if it works.

System Preference>Network>Advanced>DNS
delete the dns server ip setting. If the ip address from the dns server can't be deleted or greyed out, leave it. delete the remainder ip address (ex. 192.168.2.1)
Now configure your ip setting (most common is using dhcp setting)
set your dns server ip address to match the router ip setting
(ex. router ip address=192.168.1.1; dns server ip address=192.168.1.1)

milk242
Dec 5, 2008, 03:10 AM
You can try connecting directly to the cable modem and see if teh speed is still affected, if not then it could be like th previous poster said about your DNS settings. I had this problem happen in my network but it turned out to be the cable modem and you can also call your cable company to reset the cable modem and let them push their configuration file down to your modem.

jjtuttle
Dec 5, 2008, 11:54 AM
Try this to see if it works.

System Preference>Network>Advanced>DNS
delete the dns server ip setting. If the ip address from the dns server can't be deleted or greyed out, leave it. delete the remainder ip address (ex. 192.168.2.1)
Now configure your ip setting (most common is using dhcp setting)
set your dns server ip address to match the router ip setting
(ex. router ip address=192.168.1.1; dns server ip address=192.168.1.1)

Thanks for the response. However, this is demonstrably not a DNS issue. I've set static DNS to Verizon's multicast DNS servers. Most notably, though, slow name resolution couldn't explain dropped connections between the Mac and the router. The signal to noise ratio drops precipitously any distance from the router and is inexplicably low while sitting next to the router.

Again, thanks for responding.

jjtuttle
Dec 5, 2008, 12:03 PM
You can try connecting directly to the cable modem and see if teh speed is still affected, if not then it could be like th previous poster said about your DNS settings. I had this problem happen in my network but it turned out to be the cable modem and you can also call your cable company to reset the cable modem and let them push their configuration file down to your modem.

Hi and thanks for replying. Speeds while connected via Ethernet are as expected and match the speeds that all of the other wireless connected devices in the house achieve. The router sits logically between the Mac and the cable modem. Slow Internet connectivity is only a symptom of the more important problem- the Mac has a very tenuous connection to the wireless router.

I did discover last night, though, that changing some of the advanced configuration options available in dd-wrt v.24 do seem to mitigate the problem. Specifically, I made the following changes: I set Preamble from Long to Auto and set Frame Burst from Disable to Enable. The idea to do that came from the dd-wrt forums (http://www.dd-wrt.com/forum/search.php?search_author=molero&sid=e1dcd4c63ef4e52695d46974c405e57c). After an hour of usage last night, my wife reported no problems. I'll post back to confirm.

jjtuttle
Dec 6, 2008, 12:56 PM
It does seem that changing the parameters I listed above in the advanced wireless configuration has fixed the issue entirely. Connections between the Macbook and the Buffalo router running dd-wrt are fast and consistent, though still not quite approaching the stability and speed of Ubuntu 8.10 on my two Lenovo laptops.