PDA

View Full Version : PowerBook G4 - Black screen on start up, no chime, fan overdrives, no response




JorWesFlow
Aug 17, 2008, 11:10 PM
I've got my friend's Powerbook G4 12" 1.5GHz. She said that she left it running the other night, went to bed, then in the morning the screen was blank/black, and the fan was in overdrive. I searched many forums around the web for days trying to find similar issues and/or cure. I found some similar problems that people had, and tried a few things... I tried to reset the PMU, to no avail. I tried booting from the install disc, but it just does the same thing every time: Black screen, fast/loud fan.

I've seen some responses in similar threads say that it could be a logic board issue, perhaps it's completely shot for some reason.

I even (out of pure curiosity and a strange fascination for taking things apart) partially disassembled the PowerBook (using a guide from PowerbookMedic.com) to see if there was anything loose, or any connectors out, or whatever. Reassembled it, and still the same problem.

Any ideas? Or does anyone want to confirm that it IS indeed a bad logic board?



Firefly2002
Aug 17, 2008, 11:18 PM
That sounds exactly like a dead logic board given that there's no boot chime. Any chance it's still under warrantee?

JorWesFlow
Aug 17, 2008, 11:48 PM
That sounds exactly like a dead logic board given that there's no boot chime. Any chance it's still under warrantee?

AppleCare is long gone... is that a pretty dead on indicator of a dead logic board? No boot chime? Why would that just happen overnight?

JorWesFlow
Aug 19, 2008, 09:42 AM
Well I tried some things on my own...

Tried to reset the parameter RAM, but didn't make a difference. I also tried booting to Open Firmware to reset the PRAM that way, but still can't even get to Open Firmware.
I keep getting the same result... black screen on start up, no boot chime, fan overdrives, no response

I also:
* Tried reseating RAM: same result (black screen on start up, no boot chime, fan overdrives, no response)
* Tried starting up without RAM: no RAM tone indicator
* Tried disconnecting the battery and power source and hitting power button to discharge everything, then replaced everything: same result (black screen on start up, no boot chime, fan overdrives, no response)


Any other suggestions? I'll try them all before I buy a new logic board--if I even go that far...

Apple Genius
Jun 21, 2009, 04:49 AM
I'd kow to know WHAT exactly (which component) fails on the logic board when this stuff happens. Anyway to test it?

MacModMachine
Jun 21, 2009, 06:16 AM
try booting it into target disk mode by holding down "t" key.


also try a new stick of ram , try running it without the battery.

i have seen both of those go bad a not let a powerbook start.