PDA

View Full Version : NFS symlink works fine in Terminal, but not in other apps




sauce
Aug 21, 2008, 10:59 PM
I created a symlink to an NFS share using the following method:


$ cd ~/Projects
$ ln -s /net/server/share/data data
$ cd ~/Projects/data
$


This worked fine. It even works in Finder until it automatically unmounts. Thing is, I want apps to access this folder without opening up Terminal first.



asdf072
Aug 23, 2008, 11:17 AM
Hi Sauce,

You shouldn't have to use Terminal anymore after you create the mount point. After you enter the commands you've shown (assuming you substituted the correct host name and share path), AutoFS should mount that share for you automatically every time you boot the machine.

I'm using AutoFS to mount my iTunes library which is on an NFS share on an Ubuntu server. I originally wanted Bonjour to detect the shares, but strangely, this a bug that Apple has yet to fix.

Using the same method you used, my NFS shares are mounted when the server is on and u(n)mounted when the server goes off. This is much better than using Connect to Server in Finder, because Finder will hang if you forget to Eject your server before shutting it off.

To sum up, this isn't a fix, but it sounds like you might not need a fix. Just don't reissue the same commands in terminal. Once should be enough (but write back if it's not.)

If you still have problems, what does your entry in /etc/exports look like for this share? Most NFS problems originate here (even though it doesn't sound like it in your case)

sauce
Aug 27, 2008, 10:10 PM
Thank you, I rebooted and it was fine. It may or may not have been the result of modifying a line in auto_master with "resvport" which was a tip I found while googling.