PDA

View Full Version : MacBook wouldn't connect to internet.




smarto
Sep 7, 2008, 10:56 PM
About a month ago my 2.1 GHz MacBook stopped connecting to the internet, whether I connected via hard-wire or ethernet. I had had similar problems before, but they were fixed by resetting the p-ram. However, I wasn't able to fix this problem with that method, and was stuck without internet. Then a couple of weeks ago I left my computer shut down for a few hours and then turned it on again. It was suddenly able to connect again. Does anyone know why this happened, if turning off the computer was the solution, and if there is a quicker way to fix it if it happens again?



smarto
Sep 10, 2008, 07:25 PM
Hello again. Yesterday my computer stopped connecting to the internet while I was using it. I tried reseting the p-ram again, to no avail. Now, after leaving it off over night it still won't connect. Nothing seems to be working.:eek: Please help!!!

corbywan
Sep 10, 2008, 08:20 PM
Are you on a network? Is yours the only one that can't connect?

smarto
Sep 11, 2008, 09:56 PM
Yes, I was on a wifi network provided by an Airport Express with one other Mac. The other computer is still functioning fine. The airport symbol in the menu bar still shows that I am connected. I have also tried connecting directly to my cable modem with my computer. It has not worked. I think that there might be a problem with how my computer is reading the information coming from my cable modem. Does this help?

smarto
Dec 8, 2008, 02:15 PM
I might have figured out a fix for my problem. In the network pane of System Preferences I went to Airport:Advanced:DNS and added a DNS server with my router's i.p. address. I hope this works for anyone else who's having this problem!:-)

smarto
Jan 7, 2009, 10:01 AM
I believe that the DNS fix has worked! After having problems on another network, I came home and found that because I had manually inputted a DNS server for my router, it was still there and there was no need to do it again. My computer got onto the internet on the first try. I think that this is a real fix!:)

smarto
Jul 7, 2009, 10:21 AM
When I tried to use the DNS fix again it didn't work. I have now found that going to the Security panel of System Preferences and changing the firewall to accept all, leaving it there for a minute, and then changing it back is working. This makes me think that something in the firewall is malfunctioning. This fix has worked the last few times.