PDA

View Full Version : Help! Installing 10.5 in Powerbook G4




kennyli
Nov 10, 2008, 03:37 AM
Just got a good old classic Titanium Powerbook G4 with a bargain price. :D

It was installed with 10.4. No recovering DVD was included.

I tried to upgrade it to 10.5, by using Cabon Copy Cloner to clone the whole harddisk from my White Macbook with 10.5

Yes, I know I was stupid! As a result, the G4 will power up but always hang at the grey Apple logo screen!

I've tried to reinstall 10.5 from DVD. But the G4 will not read Double Layer DVD. It was a backup of a retail version of 10.5. My other installation disk are only recovering DVD so it won't install in this G4.

What can I do now? How can I install 10.5 in this G4?

Thanks guys.



CalMin
Nov 10, 2008, 09:26 AM
10.5 is not officially supported and CCC from an Intel to a PowerPC is not a good idea.

10.3 is probably your best bet on that hardware, if you can source an install CD.

kennyli
Nov 10, 2008, 02:26 PM
10.5 is not officially supported and CCC from an Intel to a PowerPC is not a good idea.

10.3 is probably your best bet on that hardware, if you can source an install CD.


I know it was a stupid idea to clone 10.5 from an intel to a powerpc ...... !

Anyone can give me a helping hand?

bpd115
Nov 10, 2008, 02:38 PM
USB DVD Drive and install Leopard from that..

California
Nov 10, 2008, 02:48 PM
You are going to have to get a retail disc of some kind, Tiger, Leopard.

I have Tiger and Panther if you need them.

mnemons
Nov 10, 2008, 03:16 PM
You can create a partition on your hard drive and make a clone copy of your Leopard Retail DVD on that specific partition.
Then start up your PB G4 while choose the partition as your start up hard drive, you should have no problem to install system.

kennyli
Nov 10, 2008, 03:31 PM
USB DVD Drive and install Leopard from that..

I've tried to boot up from an external harddisk connected by firewire, but my G4 will not recognise it. Will USB DVD works with G4?

kennyli
Nov 10, 2008, 03:35 PM
You can create a partition on your hard drive and make a clone copy of your Leopard Retail DVD on that specific partition.
Then start up your PB G4 while choose the partition as your start up hard drive, you should have no problem to install system.


Do you mean I create a partition by setting my G4 as target drive and them use my white macbook to create a partition in the G4, than make a clone copy of my Leopard retail DVD on that partition?

How to make a clone copy to that partition?

kennyli
Nov 10, 2008, 03:37 PM
You are going to have to get a retail disc of some kind, Tiger, Leopard.

I have Tiger and Panther if you need them.

Yes, please. Can you give me a copy so that I can save my G4 :)

TheReef
Nov 10, 2008, 03:52 PM
I've tried to boot up from an external harddisk connected by firewire, but my G4 will not recognise it. Will USB DVD works with G4?

Connect it to another Mac via FireWire, press T on the PowerBook on startup to make it appear as an external drive on the newer mac, then on the newer mac the hard drive should appear (as an installation destination), then you can install Leopard on it.

kennyli
Nov 10, 2008, 04:03 PM
Connect it to another Mac via FireWire, press T on the PowerBook on startup to make it appear as an external drive on the newer mac, then on the newer mac the hard drive should appear (as an installation destination), then you can install Leopard on it.

I've tried this method. A warning message say that I can't install on that hard drive :(

In details, I unplug my newer macbook's harddisk to avoid overwrite it. Than boot up with a Leopard installation DVD on the macbook. Than start the installation to the G4 via firewire. But once the installation starts, a warning message saying that I can't install on that hard drive.

TheReef
Nov 10, 2008, 04:18 PM
I've tried this method. A warning message say that I can't install on that hard drive :(

In details, I unplug my newer macbook's harddisk to avoid overwrite it. Than boot up with a Leopard installation DVD on the macbook. Than start the installation to the G4 via firewire. But once the installation starts, a warning message saying that I can't install on that hard drive.

You'll need to format the PowerBook's drive (from the Utilities menu find Disk Utility).
Mac HFS Extended Journaled, also make sure your not using the GUID partition map.

kennyli
Nov 10, 2008, 04:24 PM
You'll need to format the PowerBook's drive (from the Utilities menu find Disk Utility).
Mac HFS Extended Journaled, also make sure your not using the GUID partition map.


I have formatted the G4 hard drive Mac HFS Extended Journaled by using my macbook. But don't know what is GUID partition map :confused:

TheReef
Nov 10, 2008, 04:39 PM
I have formatted the G4 hard drive Mac HFS Extended Journaled by using my macbook. But don't know what is GUID partition map :confused:

There are three choices, use the GUID partition map, using the partition map for DOS and using the other one (Which I can't remember it's name) for PPC Macs.

I think you can see these under the "Options" button in the partition tab.

kennyli
Nov 10, 2008, 04:46 PM
There are three choices, use the GUID partition map, using the partition map for DOS and using the other one (Which I can't remember it's name) for PPC Macs.

I think you can see these under the "Options" button in the partition tab.


Thanks. I will try it later tomorrow.

bpd115
Nov 10, 2008, 05:42 PM
You can't install Leopard in target disk mode on the Powerbook G4 from the Macbook. It has nothing to do with partitions. The leopard disk sees the macbook hardware and will install the Intel version of Leopard onto the Powerbook Hard Disk which requires the PPC version.

A USB DVD Drive will do the trick. I've installed Leopard on a PPC mini from a USB drive before....

OrangeSVTguy
Nov 10, 2008, 06:34 PM
You can't install an Intel Macbooks Leopard software on a G4 PCC Mac. I don't why you were still trying as that was described after the second post. It doesn't matter how you partition your hard drive or how you format it. You will have to buy a Retail DVD of Leopard or Tiger to install the software on your mac. And yes using an external DVD drive via USB will still work to install the software on a PPC mac. You can also find OS cds on ebay specifically tied to the G4 Powerbooks for $20 or less.

TheReef
Nov 10, 2008, 06:41 PM
You can't install an Intel Macbooks Leopard software on a G4 PCC Mac. I don't why you were still trying as that was described after the second post. It doesn't matter how you partition your hard drive or how you format it. You will have to buy a Retail DVD of Leopard or Tiger to install the software on your mac. And yes using an external DVD drive via USB will still work to install the software on a PPC mac. You can also find OS cds on ebay specifically tied to the G4 Powerbooks for $20 or less.

You can't install Leopard in target disk mode on the Powerbook G4 from the Macbook. It has nothing to do with partitions. The leopard disk sees the macbook hardware and will install the Intel version of Leopard onto the Powerbook Hard Disk which requires the PPC version.

A USB DVD Drive will do the trick. I've installed Leopard on a PPC mini from a USB drive before....

The OP is using the retail disk.

As for choosing the partition map…it specifically states select GUID for booting on Intel Macs, and the other for booting on PPC Macs, it doesn't matter what architecture the installer is running on.

kennyli
Nov 11, 2008, 03:09 PM
Guys, thank you for your help. Here is the latest progress ........

1. Yes, external USB DVD will do the job. I can start the installation. But ......

2. A message is stopping me ...... it said "Mac OS X cannot be installed on the computer" ! See attached photo

3. I did format the partition to GUID partition map

What can I do now?

TheReef
Nov 11, 2008, 03:25 PM
Did that message come up before the installer loads, or after you clicked install?

I think it might be the fact that the minimum OS that the Macbook accepts is higher than 10.5.0 (your retail version).

I could be wrong about the host machine, it may need to be PPC. Strange, why include the option.


Edit: you don't want to be using the GUID partition map on the PowerBook.

kennyli
Nov 11, 2008, 03:36 PM
Did that message come up before the installer loads, or after you clicked install?

I think it might be the fact that the minimum OS that the Macbook accepts is higher than 10.5.0 (your retail version).

I could be wrong about the host machine, it may need to be PPC. Strange, why include the option.


The message came up after the installer loads. After I select what language to be installed.

Please, what else I can do?

TheReef
Nov 11, 2008, 03:50 PM
The message came up after the installer loads. After I select what language to be installed.

Please, what else I can do?


So you changed the PowerBook's drive to the PPC APM?

EDIT: If it's after the language then I think it is due to the minimum OS problem.

The only solution I can think of is using a host computer with a lower minimum OS (like Panther or Tiger) (and still supports Leopard).
Any of your mates have slightly older Macs?



You could install it from the PowerBook but would require a hack: EDIT: sorry it requires the PowerBook to have an OS in the first place…

http://lowendmac.com/osx/leopard/unsupported.html


You would put the disk into the PowerBook but as you state it won't read the disk, so instead put the disk in the intel mac, and start the intel mac up in target disk mode (So the intel mac shares it's DVD drive with your PowerBook), then do the process from there.

kennyli
Nov 11, 2008, 05:47 PM
So you changed the PowerBook's drive to the PPC APM?

EDIT: If it's after the language then I think it is due to the minimum OS problem.

The only solution I can think of is using a host computer with a lower minimum OS (like Panther or Tiger) (and still supports Leopard).
Any of your mates have slightly older Macs?



You could install it from the PowerBook but would require a hack: EDIT: sorry it requires the PowerBook to have an OS in the first place…

http://lowendmac.com/osx/leopard/unsupported.html


You would put the disk into the PowerBook but as you state it won't read the disk, so instead put the disk in the intel mac, and start the intel mac up in target disk mode (So the intel mac shares it's DVD drive with your PowerBook), then do the process from there.


Thank you very much for your help. I've got the whole idea now.

Will borrow a Tiger DVD from a friend and install it first.

Thanks again.

kennyli
Nov 11, 2008, 06:54 PM
I've found a more easy way:

http://forum.insanelymac.com/index.php?showtopic=89640


For those with 667Mhz PowerBooks (Or possibly other Macs that don't work with LeopardAssist):

1.) Place the 10.5 Install disk in your drive.
2.) Restart your Mac (don't use on the installer on the disk)
3.) After the chime, hold down COMMAND+OPTION+O+F until you see a light gray screen with black text
4.) let go of the keys and type in the following commands EXACTLY as shown, and hit the RETURN key after each line (you will see an "ok" confirming what you typed was correct):


dev /cpus/PowerPC,G4@0
d# 867000000 encode-int " clock-frequency" property
d# 867000000 encode-int " min-clock-frequency" property
d# 867000000 encode-int " max-clock-frequency" property
multi-boot

Select Leopard Install DVD

OrangeSVTguy
Nov 11, 2008, 08:08 PM
.........

I've tried to reinstall 10.5 from DVD. But the G4 will not read Double Layer DVD. It was a backup of a retail version of 10.5. My other installation disk are only recovering DVD so it won't install in this G4.

.......

Thanks guys.

Do you ever think it could be just the copied DVD? Sounds like it could be a bad backup or the source you got it from either downloaded or from a friend DVD, it wasn't copied or burnt right so it causes the errors. Have you tried that Backup DVD on another system that meets the OS's basic system requirements, like on your Macbook?

Firefly2002
Nov 11, 2008, 08:16 PM
Go for 10.4.11, you'll be happy with it.

monkey86
Nov 11, 2008, 11:19 PM
osx 10.5 has a minimum processor speed limit it will not install to a machine with a processor speed below 867mhz you dont need leopard on a ti pb, i have it on my g4 12" sig and im going back to tiger! use 0sx 10.4 and you'll be fine.

kennyli
Nov 12, 2008, 12:38 AM
Problem solved with the help from:

http://forum.insanelymac.com/index.php?showtopic=89640

Almost everything working fine with my good old 10.5 G4 :D

Except ........ the airport card seems don't like 128bit HEX WEP key and refused to join my wireless network at home! No problem with unsecured wifi network! Strange :confused:


PS: I am posting this reply with my 10.5 G4

kennyli
Nov 12, 2008, 05:34 AM
Problem solved with the help from:

http://forum.insanelymac.com/index.php?showtopic=89640

Almost everything working fine with my good old 10.5 G4 :D

Except ........ the airport card seems don't like 128bit HEX WEP key and refused to join my wireless network at home! No problem with unsecured wifi network! Strange :confused:


PS: I am posting this reply with my 10.5 G4


Finally, the airport card problem is solved too. Have to manually select the connection type from the network preference.

Got myself a classic Powerbook, and also learnt some lessons. Money well spent :)

TheReef
Nov 12, 2008, 05:45 AM
Finally, the airport card problem is solved too. Have to manually select the connection type from the network preference.

Got myself a classic Powerbook, and also learnt some lessons. Money well spent :)

Congrats on getting it all running smoothly!
Have fun :D

kennyli
Nov 12, 2008, 06:15 AM
Congrats on getting it all running smoothly!
Have fun :D


Thank you very much for your help. Very much appreciated :)

Sometimes, when you are getting full with the latest technology, switch back to some good old classic will make you feel younger :D

OrangeSVTguy
Nov 12, 2008, 08:53 AM
Congratulations on your downgraded computer's upgraded operating system. Just curious though, do you have 1gb installed?

kennyli
Nov 12, 2008, 11:14 AM
Congratulations on your downgraded computer's upgraded operating system. Just curious though, do you have 1gb installed?

Downgraded computer's upgraded operation system ...... I like it :D

Actually, I have 512+128MB installed now. Will find the other 512MB soon to replace the 128MB.

Brandonmeier
Nov 12, 2008, 08:32 PM
Im glad im not the only one using a powerbook G4. I recently reformatted and upgraded to 10.5 with no problems at all, but then again i bought the 10.5 from the apple store. The whole computer runs faster/smoother...kind of weird.

California
Nov 13, 2008, 06:10 AM
Disable Dashboard when using leopard on a PBG4. Saves CPU.

kennyli
Nov 13, 2008, 08:23 AM
Disable Dashboard when using leopard on a PBG4. Saves CPU.

Running Leopard in G4 is good enough. Even with the Dashboard turned on :)