PDA

View Full Version : HELP! iBook G4 wont recognize Hard drive!




marclapierre13
Nov 13, 2008, 11:31 PM
Ive searched all over, and cant find a solution.
I put in a new HD for the 1.2ghz iBook 12", and it wont be recognized by the computer. I tried resetting the Vram/Pram, with no success. I also made sure the hd connector is connected.
When I hold down "C" to the install disc, it reads the disc, but does not detect the HD. When I do not hold down c, it takes me to a question mark/folder icon.

I do not think its the new hard disk or connector or logic board, because I have read others having the problem...some say it is the firmware, and that its the OS/Installer disc that has the error...but I have no clue how to fix it.



marclapierre13
Nov 14, 2008, 10:49 PM
anyone?

jodelli
Nov 15, 2008, 12:23 AM
The iBook is limited to parallel ata drives.
When you boot the OS disk from the C key, if you bring up 'Disk Utility' does it see the drive? You should be able to partition and format from there.

marclapierre13
Nov 16, 2008, 01:59 PM
The iBook is limited to parallel ata drives.
When you boot the OS disk from the C key, if you bring up 'Disk Utility' does it see the drive? You should be able to partition and format from there.

No, the disk utility does not recognize the HD.

California
Nov 16, 2008, 04:30 PM
Did you put the new OS on the drive? I mean, start up from the system disc to install?

kennyli
Nov 16, 2008, 05:31 PM
1) Can you G4 still reads the OLD hard drive?

2) What's the size of your new hard drive? 250MB? 320MB? 500MB?

It seems to me that if your G4 can still read the old HD, than it may not support your new HD volume. In PC terms, the BIOS is not updated to read the new HD.

r.w.b
Dec 23, 2011, 03:55 PM
Three years too late, but, for anyone else with the same problem, it's worth checking the other end of the hard drive ribbon cable, which is attached to the lower side of the mainboard, and secured by a piece of sticky tape. It comes undone quite easily, and is easily missed. The tape holds the cable, but the plug is undone. That one happened to me yesterday, on two iBooks. It took a while to spot the problem. Once corrected, the computers worked fine.