PDA

View Full Version : 2.2 SDK Released




jnic
Nov 21, 2008, 05:25 AM
... just in case you haven't updated yet, the 2.2 SDK is out :)

Direct download: http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_for_iphone_os_2.2__9m2621__final/iphone_sdk_for_iphone_os_2.2_9m2621_final.dmg
Advisory: http://developer.apple.com/iphone/download.action?path=/iphone/iphone_os_software_preinstallation_advisory/iphone_os_2.2_preinstallation_advisory.pdf



jclardy
Nov 21, 2008, 07:03 AM
I don't understand the advisory...Does that mean we will only be able to build for 2.2 with this sdk, or can you still build for 2.0?

tyr2
Nov 21, 2008, 07:18 AM
I don't understand the advisory...Does that mean we will only be able to build for 2.2 with this sdk, or can you still build for 2.0?

Should be fine. I think it just means that you will need an upgraded phone to work with this version of the SDK, i.e.for deployment from XCode to work. However you should still be able to pick the old SDK versions when building the apps and then deploy these to other versions. IIRC 2.1 had the same note.

Anywhere we can find a list of changes in the API?

jclardy
Nov 21, 2008, 12:16 PM
Ok thanks, I was wondering if someone could do me a HUGE favor. I updated my ipod touch 1G to 2.2 last night..My app qTip lite has ads by AdMob but I can not see them on my ipod since the update. If someone with an iphone or ipod touch with 2.2 installed could download and try my app (its free, http://linktoapp.com/qtip_lite) and see if the ads display. Im trying to figure out if 2.2 broke my ads or if it is just my ipod...

Pring
Nov 21, 2008, 12:26 PM
Ok thanks, I was wondering if someone could do me a HUGE favor. I updated my ipod touch 1G to 2.2 last night..My app qTip lite has ads by AdMob but I can not see them on my ipod since the update. If someone with an iphone or ipod touch with 2.2 installed could download and try my app (its free, http://linktoapp.com/qtip_lite) and see if the ads display. Im trying to figure out if 2.2 broke my ads or if it is just my ipod...

I use AdMob for my ads and it works fine. It's probably just your fill rate. AdMob seems to have an average of a 75% fill rate these days which means 1 in 4 ad requests do not get serviced.

fenrus110
Nov 21, 2008, 12:36 PM
my project won't build anymore I'm getting a

Command /Developer/usr/bin/ibtool failed with exit code 5 in one of my xibs that hasn't been modified but worked in 2.1

jclardy
Nov 21, 2008, 12:50 PM
The reason i'm asking is because I have two other apps with admob ads..(One is yours, actually, sleeps2xmas) and Checkers. Checkers will still display ads but no matter how many times I try I can't see any ads in my app or sleeps2xmas.

Also AdMob has a new build of their SDK so I was wondering if you needed to build with this new build in order for ads to show on 2.2

fenrus110
Nov 21, 2008, 12:54 PM
it seems that when I set the hidden attribute in my objects in Interface Builder, it caused the error. I unchecked the hidden and am just going to code that instead.

beachdog
Dec 12, 2008, 09:57 AM
it seems that when I set the hidden attribute in my objects in Interface Builder, it caused the error. I unchecked the hidden and am just going to code that instead.

Hmm, the same thing happened to me since the 2.2 upgrade -- not immediately though, but just today it started happening for some reason. I can also work around it by setting the hidden property programmatically, but is this a known bug, or is it possible I am doing something else wrong?

nottooshabby
Dec 14, 2008, 05:30 PM
Is anybody building with this SDK yet? I'm still using the 2.1 SDK and building my app for 2.0 to ensure it's compatible with everything out there.

thevibesman
Dec 17, 2008, 04:48 PM
I just got my confirmation for the paid developer program and was wondering if someone using this version of the SDK can answer a question for me (as I have never run any apps outside of the simulator yet): am I still able to build for 2.0 using this version? I will have to update my phone to 2.2 to start using this version of the SDK though, right?

Also, I have just been playing with the SDK and simulator a little bit between projects recently and I think I'm still using the 2.0 version but I'm not 100% sure (still a little bit of an XCode neophyte). When I go to View>Set Active SDK it only lists 2.0 device and simulator, it would list both 2.0 and 2.1 if I had upgraded?

P.S.: I ask because I have SDK 2.0 installed on my desktop and I'm visiting family over the Holidays and will need to be developing on my laptop and 2.2 is the only SDK I see on the site. Is there a part of the dev. center I haven't found that has legacy SDK versions?