PDA

View Full Version : CoreAudio problems after 2.2 upgrade -- URGENT!




dbredesen
Nov 22, 2008, 12:53 AM
I released an application which plays AIFF files through CoreAudio. Since the 2.2 upgrade, users have been complaining that audio doesn't play anymore. I have verified this behavior on my handset. Basically, after AudioQueueStart(..), the playback callback never gets called, so audio data never gets queued to play. And, in iPhone Simulator, I get the below error on the console when attempting to load the AIFF file for playback.

This has worked fine prior to 2.2. Can anyone advise?

Thanks,
Dave

Error below----------------------

2008-11-22 01:47:51.748 xxxxx[7365:20b] Error loading /Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder: dlopen(/Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder, 262): Symbol not found: _SCDynamicStoreCopyConsoleUser
Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator2.2.sdk/System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
=shlibs-removed,shlib-info=[num="65",name="DivX Decoder",kind="-",dyld-addr="0x4c54000",reason="dyld",requested-state="E",state="E",path="/Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder",description="/Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder",loaded_addr="0x4c54000",slide="0x4c54000",prefix=""]



SameeraB
Nov 23, 2008, 10:01 PM
remove that component from the /Library/QuickTime folder..