View Full Version : How do you share a folder in Fusion?

Dec 9, 2008, 02:07 AM
I am utterly baffled. I have seen all sorts of threads about how to make a shared folder appear, but how do I create it in the first place? People mention "Options" in Fusion, which I cannot find, and "Add Shared Folder", which I cannot find. The Fusion help doesn't mention how to do the first step of creating the folder, although it describes the next four hundred steps in detail.

Dec 9, 2008, 02:11 AM
You can drag files directly from the Fusion window onto your OS X desktop. If you want to share files on the network, that would require setting up a Windows share within Windows.

Dec 9, 2008, 02:46 AM
You can specify a folder on your Mac that is shared to your virtual machine in Fusion, without having to use any kind of network file sharing protocol.

To do this:

Pick an existing folder to share or create a new one in OS X - remember where it is located.
Open VMware Fusion but do *not* launch a virtual machine.
In the Virtual Machine Library window, click once on the Virtual Machine you'd like to configure with a shared folder.
Click the "Settings" button (bottom part of Virtual Machine Library window)
A new Settings window will open for that Virtual Machine. You'll notice a Sharing icon. Click it.
Click the "Share folders on your Mac" checkbox.
Click the + button and select the folder you would like to share (the one you identified in step 1)
Optionally, you can click the checkboxes next to Desktop/Documents/Music/Pictures to share those folders (I usually don't bother, and just share a specific folder)
You can also set permissions for VMware on the folder at this point (Read only, or read/write, etc.)
Close the settings window and start up your virtual machine!

You'll need to install the VMware tools in your virtual machine in order to access the shared folder - you should see a Shared Folders icon on your desktop if you're running Windows in your VM. Voila!

Dec 9, 2008, 03:24 AM
Click the + button and select the folder you would like to share (the one you identified in step 1)

The PLUS BUTTON! I wasn't seeing the plus button. That was the one and only problem between me and blissful success. This is why you're not supposed to use computers at 4 AM. Thanks.