PDA

View Full Version : My University is caching my website ...


Kwyjibo
Feb 21, 2004, 11:05 AM
My website is experienciing some issues right now. I goto school on a large campus and live in the dorms so my Uni is my ISP. Most of the people around here know about my website, and check it every once in a while.

The problem:
People who are on my university network see an older cached version. At first I thought this was a safari issue so I emptied my cache and no results. I went to my neighbors computer and he loaded one of my older stories (Coke bong) ... not the most recent puzzle story at the time. I also tried this on a computer in the computer lab that had never been to and it showed the same symptoms.

Other people at home and at other schools don't see these conditions and get the most recent version when they type in www..com.

I should note that Ican load the most recent version if i type /index.html but only then or after they update the cache.

Solutions I've tried:
I'm not good with any web languages but I'm learning as I go and my friend gave me the following meta tag
<meta http-equiv="Pragma" content="no-cache">

and said wait until they update the cache and then cehck it again. Well the code now appears on the website and its still being cached. I would like the caching to end but as I said I don't know how to fix it on my own so any well explained or simple solutions would be very nice. Thanks in Advance Kwyjibo

tomf87
Feb 21, 2004, 09:36 PM
Well, the Uni can configure their proxy server to cache it regardless of the meta tags. Some of the older CacheFlow appliances had a setting to ignore those tags, so they may be doing that.

Unless you can become buddies with the proxy admin and convince him to change it, you may very well be out of luck.

jeremy.king
Feb 23, 2004, 12:14 PM
You may want to try the Cache-Control and Expires meta tags as well.

Sometimes using all three will gaurantee that proxies nor users will see a cached version of your page.

Good luck.

<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">

<META HTTP-EQUIV="expires" CONTENT="Sat, 1 Mar 1997 00:00:00 GMT">