PDA

View Full Version : Filesharing b/w xp and osx




aeclasik
Dec 20, 2008, 07:50 AM
I'm sure this has been asked over and over and I've looked through everything to try to solve this problem but nothing's really helping. Anyways, I'm trying to connect my mbp 10.5.6 to my windows xp machine, but it only seems to be going one way (I can see my mac shared folder on my xp).

So far this is what I've done:

- System preferences > sharing > checked "file sharing" > options > turned on "share files and folders using smb" and selected the correct account.
- Made sure both Xp and Mac are on same workgroups currently named "workgroup"
- Shared a folder on Xp called "hello"
- My current netbios name for mac is "evran.local" which I can connect to in windows going \\evran.local & everything seems to work smootly.

I tried "connect to server" on the mac, typed in smb://192.168.1.100 and then another window pops up asking for username/pw. Now I wasnt entirely sure what to use for username, but I've tried homepc(netbios name) & evranpc (the user account)

Now the problem is, when I try to connect onto my windows machine it says "connection failed, you are not allowed to access this server". I'm assuming it has to do something w/ the permissions on the folder, which I cannot seem to access at all. I tried folder > right click > properties, I've looked online and everywhere it says there should be a "security" tab, which I dont seem to have. I went into to my computer > manage > shared folders > shares > hello and when i right clicked it all i got was refresh and help, there was nothing else.

Anyways, I'm really hoping someone can help me with this as I am totally confused as to what is going on. Thx.



velocityg4
Dec 20, 2008, 08:33 AM
Are you using a firewall on you XP machine? If so you most likely need to add your network ip range into a trusted zone.

The username and password being asked for is any username and password of a user account on your XP machine that has permission to access your shared folder. ie Your administrator account for one.

The Security tab is in Windows XP Pro. To access it in Windows XP Home you need to boot into safe mode.

If you are using XP Pro and cannot see the security tab then...
If you have Windows XP (http://www.bleepingcomputer.com/forums/topic43502.html#) Pro configured in a Workgroup, you will not be able to see the security (http://www.bleepingcomputer.com/forums/topic43502.html#) tab in a file or folder's properties. This guide will explain how to enable (http://www.bleepingcomputer.com/forums/topic43502.html#) this feature.


Instructions
Click on the Start button and then click on the Run option.
Type C:\ in the Open: field and press enter. (Opening any folder is fine for this step)
When the C:\ folder opens, click on the Tools menu and then select Folder Options.
Click on the View tab.
Under Advanced Settings scroll down to the end and uncheck Use simple file sharing (Recommended).
Press the Apply button and then the OK button.You will now be able to see the Security tab in a folder or file's properties.

The shared folder is not encrypted, right? That could block file sharing.

aeclasik
Dec 20, 2008, 07:27 PM
Thanks for the reply, but I had made sure the firewall was off beforehand. As for the user account, the one I was trying with was an admin account. Also what you had mentioned about the security tab worked and when I checked it, everything was full control as it should be since I was using an admin account to view the folder. As for the encryption, I'm quite sure it's not, first off I'm not tech-y enough to know how to encrypt folders (lol), but either way, I just made a new folder to test out if I could at least view it, but no dice. :(