PDA

View Full Version : E Mac not loading, need help please!




angellove
Jan 15, 2009, 05:46 PM
Hi, forgive my ignorance here! Although I've had my emac for five years now, since I had no problems with it and it did everything I needed it to (i.e. getting me through a graphic design degree and running indesign, photoshop and flash simultaneously) I've had no problems with it and therefore don't have a clue about its specifications!

Before Christmas, as I was working on it, it suddenly froze and made a strange repeated beeping noise. I turned off the power and waited for a bit, turned it back on and expected everything to be okay. But nothing happened. The power light came on, but the screen stayed black and no noise to say it was loading up.

Anyone hazard a guess as to what's happening? Tried it on a different plug socket but nothing again.

Would be extremely grateful for any insights or advice.



edgew8
Jan 15, 2009, 06:42 PM
sounds like either the power supply has gone bad or the ram is bad.

If you know a little about computers you can google what the beeps mean, they usually are indicators to tell you what is wrong

you can make an appointment to have someone at the genius bar look at it

or

you could buy a different eMac off ebay, they are going for only 129$ even for the faster models

MacHappytjg
Jan 15, 2009, 07:46 PM
if it beeps twice and the light flashes a few times its most likely ram, i wouldn't think its the power supply since it powers on and ive had bad ram before and does such a thing.

fohawk17
Jan 15, 2009, 10:26 PM
sounds like a ram issue. if you are not that technical i would suggest not replacing it yourself.


but..... if you would like to i can walk you through it. post on here and i will write how. or you can prolly find a guide on google. ram is so cheap these days you can get quite a bit for little cash