PDA

View Full Version : Eiffel Compiler on OS X?




Dev2
Feb 6, 2009, 03:13 PM
Hello,

As part of my course in computer science I'm required to install an Eiffel compiler on my laptop. I don't want an IDE, just a compiler. I have found two command line compilers neither of which I can get working.

Both of which I followed the normal instructions, obviously remove .tar wrapper and navigate to appropriate directory.
which were something like,

export SmartEiffel=/foo/SmartEiffel/sys/system.se
export PATH=/foo/SmartEiffel/bin:$PATH
sudo make

http://mac.softpedia.com/progDownload/tecomp-Download-49884.html
http://gforge.inria.fr/frs/?group_id=184

All I got were errors of missing files and uncreated directories, and one of the compilers is vague on how exactly to use the compilers if it did install.

I have also tried

http://www.maceiffel.com/

But my version of XCode is 3.x and it uses 2.x and thus fails to work.

Admittedly I'm hesitant to just download an entire Eiffel IDE such as EiffelStudio. My reason is that I have Text Mate and installed the required additional bundles to provide support for Eiffel. I have the means to write the code and have its syntax highlighted is it too much to ask for a command line compiler? Besides I have a few IDE's already installed and I don't want anymore. I'd be like those people with 30 songs and 6 media players.

Programming in C and Java on OS X has been an absolute joy in OS X its a shame the smaller languages seem to be poorly supported. I spoke to my professor and he bluntly said that I should install Windows on my MacBook. Normally I would have seen that as unnecessary and over kill for such a problem but the truth is even though I like working in OS X I need to program in Eiffel. Perhaps I will cave in an just buy EiffelStudio or some other derivative but frankly I shouldn't have to splash out a premium just to code in OS X.

Sorry if I come across as ranty but as its not Apple's fault but to be fair its their problem.

Thanks,
Sean.



LPZ
Feb 6, 2009, 04:48 PM
You might try this package (http://pdb.finkproject.org/pdb/package.php/smarteiffel) from Fink.

eddietr
Feb 6, 2009, 05:32 PM
Or if you use MacPorts, you could try this:

http://www.macports.org/ports.php?by=name&substr=eiffel

And I would assume you could just not use the GUI.

LPZ
Feb 6, 2009, 05:44 PM
Actually, I had no problem building SmartEiffel-2.3 from the tarball at http://gforge.inria.fr/frs/?group_id=184.

Just unpacked it and did the usual

./configure
make
sudo make install

from within the SmartEiffel directory. (Actually I didn't install, since the Makefile didn't have uninstall as a target.)

I have OS X 10.5.6 and XCode 3.1.