PDA

View Full Version : Peculiar iPod Touch Recognition Issue




Salavat23
Feb 21, 2009, 08:16 PM
I have a 2G 8GB iPod Touch.

It is fully recognized and charges on two of my computers, but does not charge and is not recognized on one of my other PCs.

Now for a bit of history:

It was recognized on my PC for the first week that I had it, but it never charged. After the first week, it was not recognized as well. But it should be noted that it never charged on this PC.

However, it completely works on my other PCs, charging and recognition.

Now, my PC has USB 2.0, I tried all of the USB ports, but its still not recognizing nor charging on this PC. What can I do?

Oh, and this PC is not some 10 year old hunk of garbage. I built it in 2006, and it has full support for USB 2.0.



brax.j
Feb 21, 2009, 08:47 PM
Are you using different cords for different computers? If so, its probably your cord, if you are using the same cord then it is your computers USB port. The iPod sounds fine because it works in two other computers.

Salavat23
Feb 21, 2009, 08:57 PM
Are you using different cords for different computers? If so, its probably your cord, if you are using the same cord then it is your computers USB port. The iPod sounds fine because it works in two other computers.

Same cord. And yeah the iPod is fine, and the USB ports are also fine because I constantly use tons of USB 2.0 peripherals.

brax.j
Feb 21, 2009, 09:01 PM
Windows or OS X?

RKO
Feb 21, 2009, 09:06 PM
Maybe try and reboot that pc with the iPod plugged in and see if it can recognize the new hardware that way. Stumped but you could also try disconnecting the USB card and then reconnect and do an online search for updated drivers. Could be a USB issue??????

Salavat23
Feb 21, 2009, 09:38 PM
Windows or OS X?

Windows Vista on this particular box.:)

Stumped but you could also try disconnecting the USB card and then reconnect and do an online search for updated drivers. Could be a USB issue??????

Its integrated USB. I cant take out the USB controller without a saw.

Maybe I could try changing the USB drivers. mmm...

brax.j
Feb 21, 2009, 09:59 PM
Try this http://support.apple.com/kb/HT1852 if that doesn't work your USB ports aren't functioning properly.