PDA

View Full Version : My iBook does not recognize the question mark (and others). Help!




mac-jo
Feb 24, 2009, 05:40 PM
Ièm not new to macs, but i am to my ibook g4. I just got this for my birthday and it is a secondhand Mac. I cannot for the life of me figure out how to change the question mark, apostrophe, and others on the keyboard, to actually type what they are.

This is the question mark: É
this is the slash: é
it also does the same thing for the apostrophe and the quotes

How can I change this, it is serisouly driving me batty. I would love some help here.

Thanks!



BlueRevolution
Feb 24, 2009, 05:53 PM
Sounds like you're using the wrong keyboard layout (French/French Canadian maybe?). Go into :apple: -> System Preferences -> International. I don't have a Mac in front of me right now, but you can change your keyboard layout to US in there, which is what it probably should be.

mac-jo
Feb 24, 2009, 05:59 PM
thanks for replying, itès a big issue since my desktop is down and this is all i have for my business at the moment. i went into international, but it looks like everything is selected properly. there was languages, format, and input (i think) and I checked it all to see if it seemed checked off where it should be. seems fine, so now I am not sure what to do. any other ideasÉ like can you hack into my computer and fix itÉ ;)

California
Feb 24, 2009, 07:53 PM
Easy fix is to re install the Operating system with the install discs. Did the iBook come with original install discs?

BlueRevolution
Feb 25, 2009, 02:23 AM
Okay, I'm back on OS X now. This is what you're looking for. Also note that you must deselect all other listed keyboard layouts.

Why reinstall if you don't have to?

mac-jo
Feb 25, 2009, 09:50 AM
Okay, I'm back on OS X now. This is what you're looking for. Also note that you must deselect all other listed keyboard layouts.

Why reinstall if you don't have to?

thank you SO much. I did that and found out that I had the CDN setting on as well as the US. It's now changed and working normally. Thanks again. :)

clarmar
Mar 2, 2009, 03:58 PM
I had the same problem today so I did what you said and it seems to be working fine. Except, US was marked but dimmed and I had to click on US Extended for both "US" to show the mark. ???

BlueRevolution
Mar 2, 2009, 06:53 PM
US was dimmed because you must always have at least one keyboard layout active, so when no others are enabled you can't deselect the one currently in use.

wallyman8
Mar 23, 2011, 02:55 PM
Thanks for the discussion. My dad had the same problem on his ibook g3 with ? = É, / = é and ' = è. We could not find the "international" under system preferences but simply clicked on the Canadian flag on the top bar of the screen and selected the US flag instead (I know Canada is a better country, but for mac the US flag works better with the keyboard). :0 jokes - I'm Canadian, sorry. The problem is the Canadian keyboard is FRENCH Canadian, hence the different "e's."