PDA

View Full Version : USB Apple Display monitor ports not working with Radeon Pro 9000 in Power Mac G4




pasteater
Mar 2, 2009, 03:31 PM
i recently replaced the video card on my G4 and now the USB ports on the back of my apple studio display are no longer functioning, but the monitor itself is functioning just fine. the USB ports on the tower are functioning normally. any help is appreciated.

2002 Quicksilver 933mhz G4
1.5gb RAM
17" Apple Studio Display via ADC connection

(new card)
ATI Radeon Pro 9000 64mb AGP ADC/DVI

thank you.



AlexMaximus
Mar 3, 2009, 08:11 AM
i recently replaced the video card on my G4 and now the USB ports on the back of my apple studio display are no longer functioning, but the monitor itself is functioning just fine. the USB ports on the tower are functioning normally. any help is appreciated.

2002 Quicksilver 933mhz G4
1.5gb RAM
17" Apple Studio Display via ADC connection

(new card)
ATI Radeon Pro 9000 64mb AGP ADC/DVI

thank you.

As far as I am informed, Apple's ADC connection is a DVI combined with USB and Power in one plug. The Radeon 9000 is known to have a little Pin, just in front of the AGP Bus Pins, which is used for power. Maybe there is an issue with just that and your USB is not getting powered up anymore.
Does your Display cable split up in one ADC cable and a smaller USB cable ? (This is how my Apple Cinema Plug works on the 23')

I would check these points:

Reseat the Graphic card. Inspect the little Power Pin that is between the Slot bracket and the AGP pin set. Maybe its dirty or doesn't get contact properly.
Was that card used in a different G4 then yours ? Maybe your pre-owner has tinkered with the card and did some modifications. (I have seen the card with a saw-off pin because of issues in earlier G4 Digital audio that doesn't have the little powerpin bracket on the Mainboard.)

Do you have a friend that uses a mac and has a DVI-ADC Connector. If so, you could try that in order so check on the functionality of the ports on your display.

:apple: