PDA

View Full Version : UITabBarItem image not showing properly




amalshah71
Mar 6, 2009, 05:40 AM
Hello,
i am adding tab bar and it's items through interface builder.
And then setting the UITabBarItem image....but it doesn't show properly...

It just shows a greyish image...which is not actually the image that i have...

What am i missing? Are the images for tab bar meant to different of some sort?

amal



kwarren
Mar 6, 2009, 05:43 AM
As far as I recall, they need to follow these guidelines:

30x30
PNG
Anti-aliased
Transparency set

dejo
Mar 6, 2009, 09:34 AM
What am i missing? Are the images for tab bar meant to different of some sort
Yes, they are different. The RGB channels of the image are completely ignored and you need to use the alpha channel exclusively.

amalshah71
Mar 9, 2009, 02:05 AM
Hello,
My graphics guy seems to have followed the following guidelines

30x30
PNG
Anti-aliased
Transparency set

still i have the same ouput


and one of the image is...

"The RGB channels of the image are completely ignored and you need to use the alpha channel exclusively."....what does this mean...what do i tell the graphics guy to exactly do...

If anyone could share one of the images that do work on UITabBarItem....it would be of help...

Still, what i am missing?


Thanks
amal

kwarren
Mar 9, 2009, 02:44 AM
That second image you linked to is your problem. Tab images are meant to be "cut-out" icons rather than solid squares as you have there.

Again, correct me if I'm wrong.

dejo
Mar 9, 2009, 10:37 AM
"The RGB channels of the image are completely ignored and you need to use the alpha channel exclusively."....what does this mean...what do i tell the graphics guy to exactly do...
Your graphics guy should understand what this means. If not, maybe time for a new graphics guy? :confused: