PDA

View Full Version : Choppy Youtube on my powermac g4 1.25




adamzx3
Mar 14, 2009, 02:43 PM
I have a powermac g4 1.25 (mirror door) with 1.25gb of ram running leopard, and whenever I try to watch youtube or any flash based video it is sooo laggy. would a graphics card update help or am I just screwed? My cpu activity is pegged during playback.

I have an old 9800 pro 128mb pc card but it has a 64bit rom :mad:



Abidubi
Mar 14, 2009, 02:45 PM
CPU is the problem, sorry. My single 1.8 G5 has some trouble. The old high quality worked ok, but now this HD stuff goes at about 1 frame every 5 or 6 seconds.

adamzx3
Mar 14, 2009, 02:50 PM
CPU is the problem, sorry. My single 1.8 G5 has some trouble. The old high quality worked ok, but now this HD stuff goes at about 1 frame every 5 or 6 seconds.

niiiice...

Thanks for the quick reply, and if your 1.8 struggles I guess there no point in overclocking it.

I guess a nice $400 core2duo hackintosh would fit the bill for an e-machine, my macpro is stuck at work, but at least it's getting some use now :)

Pili
Mar 14, 2009, 02:58 PM
Yeah my 1.67 powerbook struggles on everything but low quality youtube. Just the nature of todays web but thats what I have my MacPro for :)

These old machines are great though still, I'm going to have a hard time giving my pb up.

edgew8
Mar 14, 2009, 03:12 PM
Its well documented that Flash is garbage in Linux and OSX (thanks Adobe)
In theory anything above 700mhz should play Flash videos just fine..if you have windows. Sadly even CD2 Macs take a performance hit when using Flash

simplymuzik3
Mar 14, 2009, 05:56 PM
I first had a 400mz, 1gb ram powermac g4(2 months ago), and that was horrible for ANY kind of flash. Next I upgraded to a dual 800mhz, 1.5gb ram, powermac g4 quicksilver, and that was still pretty choppy. It was okay on some videos, but on others it was horrible. Now I got a powermac g5, dual 1.8ghz, 1gb ram, w/leopard and it works VERY GOOD with flash. YouTube videos look very decent, and there is no noticeable lagging or glitching etc. So I guess there is nothing you can do about that problem. I was stuck without youtube until I got my g5, about a week ago.

California
Mar 14, 2009, 06:51 PM
SO BASICALLY ADOBE is making old Macs obsolete before their time?

I upgraded to 10 flash. It crashed my quad.

Downgraded and re installed flash 9. But it was a different version of 9 than what i had previously. It crashed my quad.

What's up with Adobe?

There's got to be a flash hack for old macs....!!!!????!!!!!

edgew8
Mar 14, 2009, 07:22 PM
I first had a 400mz, 1gb ram powermac g4(2 months ago), and that was horrible for ANY kind of flash. Next I upgraded to a dual 800mhz, 1.5gb ram, powermac g4 quicksilver, and that was still pretty choppy. It was okay on some videos, but on others it was horrible. Now I got a powermac g5, dual 1.8ghz, 1gb ram, w/leopard and it works VERY GOOD with flash. YouTube videos look very decent, and there is no noticeable lagging or glitching etc. So I guess there is nothing you can do about that problem. I was stuck without youtube until I got my g5, about a week ago. do you have a temp monitoring program? check out the temps when you play a flash vid. I too don't have any smooth playback problems, however my iMac shoots up to 71c (wayyyyy too high) and user usage goes to 90% and I fear it will melt my precious iMac :mad:

There's got to be a flash hack for old macs....!!!!????!!!!!
Sadly ,no..believe me I have looked far and wide. I had to resort to using my PC whenever I want to watch my TV and anime from streaming sites and Hulu. At least my PC is hooked up to the TV and not used as my work computer. I leave everything else to my Mac.

I am patiently waiting for Adobe to get their ***** together for both Linux and OSX so I can ditch windows completely but I wont hold my breath :mad:

AlexMaximus
Mar 14, 2009, 08:15 PM
I have a powermac g4 1.25 (mirror door) with 1.25gb of ram running leopard, and whenever I try to watch youtube or any flash based video it is sooo laggy. would a graphics card update help or am I just screwed? My cpu activity is pegged during playback.

I have an old 9800 pro 128mb pc card but it has a 64bit rom :mad:

If you have the G4 MDD 1,25 DUAL, you should be "ok" from the CPU side of it and I would upgrade. If you have the single cpu model, it could be a problem and I would sell it.
Besides that, your big problem here is the lack of Ram in my opinion. Max out your Ram and you should see a major improvement.
You can not expect to have a superior performance on a system with low ram - especially on Leopard. Leopard wants to see more hardware resources! 2 Gig Ram is the minimum for Leopard out of my view.

A better video card would improve your situation further since Leopard wants a card that supports Core Image and things like that. Those things free up the CPU as well and you will see an overall system improvement.
Since the Dual 1,25 has heat issues, I would NOT go for ATI's Radeon 9800 because of excessive heat. The ATI 9600 is a way better balanced card which runs way cooler and is not that much worse on the performance end.
(I had both cards in my G4)

TDM21
Mar 15, 2009, 12:25 AM
You may want to try a different browser. I have Safari4, Firefox 3.07, and Caminio 1.6.6 installed on my PowerBook and Safari is the worse at playing anything flash. Firefox gives me good performance and Camino appears to be the best (when it isn't bugging out).

jjahshik32
Mar 15, 2009, 02:07 AM
Just get the cheapest end mac mini and up it in 4gb of RAM and it'll be 2x faster than any power mac g5 and play up to any 1080p mkv files. :D

PowerPaw
Mar 15, 2009, 03:21 AM
Totally agree on the browser comments. The new Safari beta is a lot better but I often find myself opening Firefox as Safari keeps crapping out.

Ironically I can still open up and edit pretty sizable images in PhotoShop though filters and selections are very tedious these days, its just all the junk that my browser has to load up when trying to access pages like the NY Times that kills my machine!

It's laughable to think that you can hang onto an old machine for light web browsing and email ;-) Remote desktop off a new Mac Pro 8 core with or without a VM - now there is a thought :D

adamzx3
Mar 17, 2009, 09:16 PM
Whats worse, I just got back from fixing my grandma's G4 mac mini that also has a 1.25gz chip, and only 512mb of ram.....and it plays flash vids flawlessley....in leopard!:confused::confused::confused:

I need to get her a gig of ram and spend a few $$ on some ram for mine....even though my work owns it....they get to use my MacPro for free and I get a pos g4......whats up with that :cool: