PDA

View Full Version : Partition errors in Bootcamp when booting Vista




MaskedCarrot
Mar 25, 2009, 02:06 PM
Hello, I just got my first iMac recently, so I am a MAC noob. :)

I did the Bootcamp thing, partitioned the drive and installed Vista. Everything went well and Vista works just fine. But everytime I boot into windows, I get partition errors before it boots.

For example it says:

"Warning: Unrecognized partition table for Drive 80. Please rebuild it using a Microsoft-compatible FDISK tool (err=4)"

It will come up 3 times, and then boot into Vista. Both OSX and Vista are working fine, but something is definately wrong though since I am getting this error.

I checked the forum here and the Apple forum and didn't find anyone with the same problem. So does anyong here have a clue?



apfhex
Mar 25, 2009, 02:29 PM
Is it a legitimate copy of Vista? :o

I've seen activation cracks that produce exactly this error on boot. Maybe it could happen on a legit, but modified (slipstreamed perhaps?), copy of the OS.

illegallydead
Mar 25, 2009, 02:43 PM
+1. I have the same problem, and it is because of "Vista Loader 2.x.x" or something like that.

If you do have a 100% legit copy of Vista, then get a program called Tweak VI (http://download.cnet.com/TweakVI-Basic/3000-2094_4-10584178.html). From there, go in and run a few commands that rebuild the Master Boot Record (MBR), and there was one other.

Google this problem and you will be sure to find the answer.

If you are not running a 100% legit copy of Vista (I'm not judging you either way, as I am not...) then go ahead and do this; it will solve this issue. If you are not sure or or know that it is not legit, then just grin and bare it. If you do the above described steps, it will break the method that keeps Vista from knowing that it is a fake copy, and you will have to do a completely fresh install and start over.