PDA

View Full Version : Aluminum PowerBook Corrosion


Marlon_JBT
Apr 19, 2004, 03:48 PM
Hello Fellow MacRumors Users.

I have heard many reports of PowerBook corrosion today, in the New PB / iBook topic. I'd hate to hijack that thread, talking about nothing but corrosion.

So, what does this corrosion look like? Anyone have pictures? I don't believe mine is corroded, but I do have some nicks and scratches. Would that be the corrosion that everyone is whining about?

Even if it is corrosion, I really don't mind. But this silver theme is getting quite boring. My next PowerBook is going to be sent off to get painted. :D

Diatribe
Apr 19, 2004, 04:09 PM
Geeez, why doesn't anyone search anymore before they post? :D
Look here http://forums.macrumors.com/showthread.php?t=59078
and here http://forums.macrumors.com/showthread.php?t=67313
I posted a link to a pic in the 2nd thread.
Looks pretty bad, I have yet to see it in real life though.
And for the protection: http://vixinc.com/

Marlon_JBT
Apr 19, 2004, 04:55 PM
I did search... and didn't come up with much. I didn't even discover that thread that was started on the 11th of April!

I'm sorry! :)

Diatribe
Apr 21, 2004, 01:39 AM
Don't worry. I wasn't being too serious. Sometimes I don't see the wood for the trees either.
Funny thing is... I talked to Apple Care Germany yesterday and 3 people there had never even heard about it. I actually had them look it up in the help forums at apple.com.
So either Germans are not picky with their their stuff, which we can rule out I think, or it is a problem with certain batches they shipped and these were early ones... anyways, it is all speculation.
He wasn't even sure if it was covered by the warranty because it was a cosmetic issue. I would argue over that. At least in Germany there is a law that makes them fix those things, even if it is just a cosmetic thing.
If it is their design flaw it is theirs to fix.

JFreak
Apr 21, 2004, 02:18 AM
i have hard time understanding how on earth aluminum would corrode. it shouldn't do that. can someone having this issue post a very hign resolution picture about it, i'd be interested...