PDA

View Full Version : iBook memory not recognised - problem?


djbombjack
Apr 19, 2004, 05:56 PM
So I just bought an iBook 12" G4 for my parents... opened it up, re-installed all software and OS X... and after some time, noticed that in the System Profiler, it was not recognising the extra 512mb chip I had the store install.

So I opened it up, reistalled the chip again thinking that they might've installed it badly... but again nothing.

So I reistalled the original 128mb chip, and again, nothing.
Again and again i've re-installed both chips, and still the machine does not recognise anything.

Now I know about static blowing chips, so I did take precautions... but what seems strange is that the machine just does not recognise that something is even in the slot, let alone in there and faulty.

Anyone else had this problem?

keysersoze
Apr 19, 2004, 06:13 PM
HEY! I had this EXACT same problem with my iBook G4. It's not static and the RAM is probably fine (although the slot could be bad on the logic board). Maybe (like me) you just haven't pushed the stick into the slot far enough. Open the computer up and try pressing more firmly on the RAM chip (at the 45degree angle) before locking it in. If any of the RAM chip connection is stll showing, it's not in far enough. Try it! It worked for me!

Also, have you tried the hardware utility disk? Start up from that CD and it checks RAM, HD etc. That might also point to something. If all else fails, I'd suggest taking it back and having the retailers look at it... they can check a bad logic board.

djbombjack
Apr 19, 2004, 07:22 PM
Un-*********-believable... it worked.
Thanks so much for that... if only the store *cough cough*MacWarehouse*cough cough* had bothered to check this in the first place, I could have saved a lot of time and trouble...

Once again, thank you.

keysersoze
Apr 19, 2004, 07:52 PM
Un-*********-believable... it worked.
Thanks so much for that... if only the store *cough cough*MacWarehouse*cough cough* had bothered to check this in the first place, I could have saved a lot of time and trouble...

Once again, thank you.

Glad to help-- and glad it wasn't something more serious! ;)

weemee
May 10, 2004, 05:58 AM
WOW!!! I cannot thank you guys enuogh for that wee pearl of wisdom....was surfing the net trying to find a solution to the exact same problem to my G4 ibook....tried your solution, crossed my fingers and hey presto.....

Many thanks...made my day, and stopped me swearing...

And Ive found another Mac forum to boot...hurrah! :: :cool: