PDA

View Full Version : iMac G5 Incredibly Slow




Variant
Apr 9, 2009, 10:11 AM
Hi, I've searched for answers to my problem, but keep coming up short.

Basically my iMac G5 is running incredibly slow, launching programs, running programs, ect. Its the originally release of the G5 iMacs, running the latest version of Leopard. It has over 1GB of ram and the hard drive was just replaced due to the old one crapping out.

I've checked Activity Monitor and everything seems to be taking up a reasonable amount of CPU power, nothing seems extreme. Most of the threads I've found on this issue seem to suggest running Fix Disk, but I don't think that is the problem considering the hard drive is brand new. (I had the same issue before the new hard drive).

Could something be wrong with the RAM? I've re-installed Leopard before (archive, not clean instal) and tried I've also fixing permissions. Neither seemed to fix the problem.

Thanks for the help in advance! :cool:



michael.lauden
Apr 9, 2009, 10:28 AM
go ahead and search MR first, then go to google. you will find everything you need.


i'll give you a start though - download Onyx and TinkerTool. both are free. Onyx will help clear out the crap lying in your computer, and TinkerTool will help you tweak some minimal things to keep everything running smoothly.


i highly recommend MainMenu (to run scripts, clear logs+caches, etc).


you could also use it to disable dashboard (if you don't want the program it's a simple terminal command to turn it off, and another to turn it on)

if you have a lot of widgets it may be killing your performance, and if you don't use it, then who cares if you disable it right?


hope this helps

js81
Apr 9, 2009, 10:29 AM
Hi, I've searched for answers to my problem, but keep coming up short.

Basically my iMac G5 is running incredibly slow, launching programs, running programs, ect. Its the originally release of the G5 iMacs, running the latest version of Leopard. It has over 1GB of ram and the hard drive was just replaced due to the old one crapping out.

I've checked Activity Monitor and everything seems to be taking up a reasonable amount of CPU power, nothing seems extreme. Most of the threads I've found on this issue seem to suggest running Fix Disk, but I don't think that is the problem considering the hard drive is brand new. (I had the same issue before the new hard drive).

Could something be wrong with the RAM? I've re-installed Leopard before (archive, not clean instal) and tried I've also fixing permissions. Neither seemed to fix the problem.

Thanks for the help in advance! :cool:

Use Disk Utility to repair permissions. If that doesn't seem to help, download Cocktail (http://www.maintain.se/cocktail/download.php) and use it. I just fixed a similar-sounding problem on my sister's Macbook like this.

EDIT: Totally didn't catch that you'd already repaired permissions. Go ahead with Cocktail. When I repaired permissions on the Macbook it didn't fix it, either - Cocktail did.