PDA

View Full Version : Cannot view Windows Computers in Finder




akapaul
Apr 22, 2009, 10:24 PM
My Macbook is on the same workgroup and network as my three other Windows Vista computers.

The Vista computers can all see each other's network drives.

I can view the Macbook's drive on all Vista computers.

All computers can get online and browse the web.

I can RDP into all Vista computers from my Mac.

But...
I cannot see any of the Windows shares on the Macbook. It seems everything is setup the way it should be setup (I have done a bunch of research) but I am probably missing one step. Can someone help me please? This is driving me nuts!

Thank :)
New Macbook Owner



spinnerlys
Apr 22, 2009, 10:38 PM
Have you set Finder to view Shares?
Finder > Preferences > Sidebar

http://www.askdavetaylor.com/2-blog-pics/mac-finder-preferences-sidebar-applications.png

akapaul
Apr 22, 2009, 10:55 PM
Yes - that option is checked.

As a matter of fact, when I was staying in a hotel for business, I was able to see people's computers in the Finder. One person even had shared files! Talk about being unsecured!

Ivan P
Apr 22, 2009, 11:00 PM
Yes - that option is checked.

As a matter of fact, when I was staying in a hotel for business, I was able to see people's computers in the Finder. One person even had shared files! Talk about being unsecured!

Ha! This reminds me of this hotel I stayed in two months ago, and I had iTunes open, and someone on the same network didn't realise that the Limewire folder on a computer is, by default, shared between computers. Just curiously, I clicked on their Limewire folder that had appeared under "Shared" in iTunes, only to find all sorts of pornographic videos...backed out of there pretty quick! Gave me many 'lol's.

akapaul
Apr 22, 2009, 11:07 PM
any ideas?
i am destined to fix this tonight :)

akapaul
Apr 23, 2009, 06:29 PM
anyone have any ideas? i'm sure this is a simple fix.

thanks.

spinnerlys
Apr 23, 2009, 06:46 PM
Have you tried contacting the Windows computers with your Mac via Connect To Server (Cmd+K) and the IP addresses of the Windows machines?

After that, they should show in the sidebar.

I know, this is not the same, but maybe one connection will fix it.

I once was in an open wi-fi network, and I could see Windows shares, and I only had File Sharing on. It could be something on the Windows side.

I'm sorry, but there is nothing more (if that is even more) for me to add.

velocityg4
Apr 24, 2009, 06:27 AM
Have you tried contacting the Windows computers with your Mac via Connect To Server (Cmd+K) and the IP addresses of the Windows machines?

After that, they should show in the sidebar.

I know, this is not the same, but maybe one connection will fix it.

I once was in an open wi-fi network, and I could see Windows shares, and I only had File Sharing on. It could be something on the Windows side.

I'm sorry, but there is nothing more (if that is even more) for me to add.

This is what I do. I just save the IP Addresses in the connect to server dialog. In My Network Places on the Windows computers I type the workgroup and computer name in the address bar. By the way you need to type in the Samba address for the Windows computers. If you just type 192.168.x.x it will try to connect via appletalk (afp) instead type smb://192.168.x.x

For some reason network browsing stopped functioning properly on my network. If I did not type this info manually, in Windows I would instead have to go to configure TCP/IP and disable then re-enable Netbios. Which is too much of a pain.

The problem seems to be caused by my router but factory resets failed to correct this. I have also run full network resets in Windows but this does not fix it, i.e. 'netsh int ip reset c:\reset.log' and 'netsh winsock reset catalog'. It also is not a Firewall problem as my firewall is set up to allow my networks ip range but I tried disabling the firewall's to the same result.

akapaul
Apr 24, 2009, 11:30 AM
By the way you need to type in the Samba address for the Windows computers. If you just type 192.168.x.x it will try to connect via appletalk (afp) instead type smb://192.168.x.x

Thank you!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :D