PDA

View Full Version : Problems connecting to Mac from XP


ljsimms@buffalo
May 3, 2004, 08:10 PM
I am having no luck setting up windows file sharing on my G5 running 10.3.3 so that a Windows XP machine in my lab can access it. I've turned Windows file sharing on, set the appropriate privileges, and set the proper windows workgroup in Directory Access. SMB is also turned on in Directory Access. Despite all of this, every time I try to connect to the G5 from the XP machine using the standard procedures (i.e., "\\computer\shortname", I get something like "Network Drive Cannot be Found...."

I have tried going into the the smb.conf file directly and also using SharePoints to create a new share, all to no avail. Interestingly, I also cannot ftp into my G5, despite having that also tuned on in the sharing panel. AFP works fine though between the g5 and other macs in the lab.

I have also tried repairing privileges and repairing the drive. Did not fix the problem.

Firewall is turned off.

Interestingly, I can connect from the xp to another iMac in the lab (running jaguar), but not my G5. This makes me wonder whether I have a hidden configuration problem on my G5?

Any ideas about what might be going awry here or things I could try? I'm really pulling my hair out.

Thanks.

mklos
May 3, 2004, 08:45 PM
I am having no luck setting up windows file sharing on my G5 running 10.3.3 so that a Windows XP machine in my lab can access it. I've turned Windows file sharing on, set the appropriate privileges, and set the proper windows workgroup in Directory Access. SMB is also turned on in Directory Access. Despite all of this, every time I try to connect to the G5 from the XP machine using the standard procedures (i.e., "\\computer\shortname", I get something like "Network Drive Cannot be Found...."

I have tried going into the the smb.conf file directly and also using SharePoints to create a new share, all to no avail. Interestingly, I also cannot ftp into my G5, despite having that also tuned on in the sharing panel. AFP works fine though between the g5 and other macs in the lab.

I have also tried repairing privileges and repairing the drive. Did not fix the problem.

Firewall is turned off.

Interestingly, I can connect from the xp to another iMac in the lab (running jaguar), but not my G5. This makes me wonder whether I have a hidden configuration problem on my G5?

Any ideas about what might be going awry here or things I could try? I'm really pulling my hair out.

Thanks.

Since you can connect to the Mac from the PC it sounds to me like something on the PC side isn't configured correctly. All you have to do on the Mac side is just go into the Sharing System Pref and check the Windows File Sharing checkbox and your all set. On the Windows side you need to share some kind of folder. I believe the C Drive is shared by default. So try putting in smb:\\computernameoripaddress\c$ and it should prompt for a username/password. Make sure you use the Windows username/password and NOT the Macs. I've been told before that the Windows username/password and the Mac username/password have to be the same but I don't think thats true.

ljsimms@buffalo
May 3, 2004, 10:22 PM
I think you are misunderstanding the problem I'm having. I cannot get my PC to connect to my G5 for filesharing (i.e., I want to be able to see the Mac when sitting in front of the PC).