PDA

View Full Version : Can't send mail with mac mail




Littleboo
Jun 4, 2009, 10:45 AM
All of a sudden I cannot send mail from my main Mac. My other 2 work fine so I know it's program issue.

I called my internet provider and they told me i had to contact Apple so I thought I'd start here.

She did suggest that I delete my mail account and set it back up. I'm willing to try this, but I can't loose all my mail. So, I have a back up on time machine if I need it, but I'm not sure how to re enter it into mail.

thanks



thunderweb
Jun 4, 2009, 11:01 AM
Go to Finder, click on the Library folder under your user account, find the Mail folder, click on whichever account your deleting and copy the mbox to your desktop. Then go into Mail and delete the account. Then select file and click on Import Mailboxes. Select mbox and find the files and import them. Once you've done that select Mailbox in the menu bar and click Archive Mailbox. That should do it for ya. Make sure you copy over all your folder mboxes and your account mboxes. For example I marked my Mail accounts blue and my folders green. I hope that makes sense. Good luck!

Littleboo
Jun 4, 2009, 11:15 AM
I tried to import, but couldn't. Said no valid files. I entered a new account in but it did not solve the issue. Any other thoughts on what could work?

thunderweb
Jun 4, 2009, 11:18 AM
Have you tried to reinstall Mail with your install discs?

Littleboo
Jun 4, 2009, 11:26 AM
good Idea. I don't know how.

thunderweb
Jun 4, 2009, 11:34 AM
It's a little complicated but download Pacifist (http://www.charlessoft.com/) . It allows you to install individual apps from the OS X install disks. You pretty much just put the disk in and open that app. If you need further instruction just ask but I think you should be able to figure it out :)

Littleboo
Jun 4, 2009, 12:12 PM
So, I believe I did it right. I deleted the mail from applications, then I downloaded Pacifist and dragged the mail icon to the harddrive application folder. it extracted and when I opened it and went to import the mbox files I get an error: No valid mbox files were found. I also tried to put the folder back into Library folder, but that account is not showing up.

thunderweb
Jun 4, 2009, 12:14 PM
So, I believe I did it right. I deleted the mail from applications, then I downloaded Pacifist and dragged the mail icon to the harddrive application folder. it extracted and when I opened it and went to import the mbox files I get an error: No valid mbox files were found. I also tried to put the folder back into Library folder, but that account is not showing up.

I had that problem once as well, I think I wrote down how to fix it but lemme check...

thunderweb
Jun 4, 2009, 12:16 PM
Make sure you are selecting the folder that contains the mbox files and not the mbox file itself. Also you should do a Repair Permissions through Disk Utility.

Duff-Man
Jun 4, 2009, 12:25 PM
Duff-Man says...if the repair permissions does not help, you may want to try creating another user account on the computer (it's handy to have one for testing and troubleshooting like this anyway) and creating your mail account there. If it works then then the problem is not with the Mail app itself but with something in *your* user account, perhaps as simple as the preference file being corrupted in some way....oh yeah!

Littleboo
Jun 4, 2009, 04:55 PM
verify/repair didn't work. I made a new account and that account can send mail, so then it must be a preference? what do I do?

Littleboo
Jun 4, 2009, 05:33 PM
I tried to remove all plist files and rebooted but nothing.