PDA

View Full Version : recovering iPod songs...and I've read the guide




raythepa
Jun 4, 2009, 11:37 AM
I'm trying to recover songs from my daughters iPod onto an XP PC. I'm assuming that the hidden folder that I am looking for is located in My Computer>iPod. If that's true, any suggestions as to why the iPod isn't showing up in My Computer?

Thanks in advance for the assist!



swiftaw
Jun 4, 2009, 11:39 AM
Okay, go into iTunes. The iPod should show up there. If it asks you if you want to sync, tell it no, else you'll erase the ipod. In the ipod settings in iTunes enable iPod disk mode. The ipod should now show up under My Computer.

raythepa
Jun 4, 2009, 11:49 AM
That looks like it is doing it. I dragged the "music" folder with all of the "F" prefix folders to the desktop (looks like that might take a few minutes), then I will drag copied folder into iTunes. I think that will do it, rebuilding this library for my daughter has been a pain, but I'm looking at a refurbed iMac for them.

raythepa
Jun 4, 2009, 12:32 PM
OK still having a problem and I didn't want to start a new thread.

After completing my copying I have a faded out folder titled music on my desktop. I drag it into iTunes and nothing happens. If I open one of the "F" folders, select all and drag into iTunes, I get a bunch of new songs with exclamation marks in front of them.

I'm close... any other guidance?

raythepa
Jun 4, 2009, 12:49 PM
Actually all of the songs from the iPod are now in the music library but when I click on a song with an exclamation point i get a pop-up stating..."the original file could not be found". So I guess I need to get the original file into iTunes. Any help?

swiftaw
Jun 4, 2009, 01:47 PM
The problem is that all the files are no in different locations that where they were before.

If you don't care about keeping play counts etc. you can do the following.

1. Connect ipod,

2. Drag hidden music folder to desktop

3. Open iTunes

4. Delete all entries in the library

5. Got to Add to Library and select the Music folder you copied off your iPod.

6. Your iTunes library should repopulate with all the songs that were on the iPod.

raythepa
Jun 4, 2009, 03:00 PM
I've done all of the things you've suggested. When I try to add folder the folder doesn't show up in the options. Dragging the entire folder onto iTunes isn't doing it either. So i opened all of the individual "F" folders and dragged them into iTunes, when I did that they showed up in the music library fine and they played fine, but when I delete the folder from the desktop the songs stopped.

Just tried to use Windows explorer to move the "F" file into iTunes, which seems to work but when i delete the desktop folder again the songs stop. Will try a restart and see what happens

swiftaw
Jun 4, 2009, 03:01 PM
I've done all of the things you've suggested. When I try to add folder the folder doesn't show up in the options. Dragging the entire folder onto iTunes isn't doing it either. So i opened all of the individual "F" folders and dragged them into iTunes, when I did that they showed up in the music library fine and they played fine, but when I delete the folder from the desktop the songs stopped.

Just tried to use Windows explorer to move the "F" file into iTunes, which seems to work but when i delete the desktop folder again the songs stop. Will try a restart and see what happens

In iTunes preferences there is an option to copy files to iTunes Music Folder when adding to library, make sure that is checked before importing the files from the F folders.

raythepa
Jun 4, 2009, 03:50 PM
The copy preference was not checked. I went back and repeated the sequence and although the songs are in the iTunes folder in My Documents they still don't show up in the playlist. This is so strange because I was able to import another set of songs into a music library from an external HD without any problem.

Thanks for all your help on this swiftaw maybe some others will have a clue that can help me out.